VPS侦探论坛

 找回密码
 注册
搜索
热搜: pathinfo
查看: 750|回复: 6

军哥 php安装失败,MariaDB和Nginx成功

[复制链接]
发表于 2018-6-14 10:32:29 | 显示全部楼层 |阅读模式

服务器:阿里云 2核4G,Ubuntu 16.04安装:lnmp,nginx-1.14.0mariadb-10.2.14php-5.2.17最后提示php安装失败

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x

美国VPS、VPN、域名代购:http://shop63846532.taobao.com/

发表于 2018-6-14 14:10:11 | 显示全部楼层



这就是典型的新老搭配,php 5.2支持不了mariadb 10.2

美国VPS、VPN、域名代购:http://shop63846532.taobao.com/

发表于 2018-6-28 17:48:47 | 显示全部楼层

回复 2# 的帖子




军哥,有啥推荐的搭配?
或者搭配列表有木有?
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org/
发表于 2018-6-28 18:04:45 | 显示全部楼层

回复 3# 的帖子


新的最好搭配新的,总之最忌讳的就是一个最老的一个最新的,系统版本和程序搭配同理

美国VPS、VPN、域名代购:http://shop63846532.taobao.com/

发表于 2018-6-30 14:22:44 | 显示全部楼层

内存比较小的,比如512MB的。在网上看到php5.6不如php7.2,且差距明显(比如耗内存、反应速度慢),这种情况下打算安装是用mysql5.5配合php5.6呢还是7.2比较好?
看到那个自动代码默认的是mysql5.5配合php5.6的,我估计mysql5.5要比mariadb5.5更好一点?
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2018-7-1 10:55:30 | 显示全部楼层

回复 5# 的帖子


mysql 5.5和大部分版本都是搭的,mysql5.5基本上等于mariadb5.5
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org/
发表于 2018-7-2 23:05:08 | 显示全部楼层

看来我只能停留在5.5版上了
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org/
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2019-5-25 12:23 , Processed in 0.046187 second(s), 27 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表