VPS侦探论坛

 找回密码
 注册
搜索
查看: 461|回复: 1

安装lnmp1.5一直失败

[复制链接]
发表于 2018-12-10 11:27:40 | 显示全部楼层 |阅读模式



天翼云服务器 Ubuntu 18.04  64位    lnmp1.5一键安装包

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x

美国VPS、VPN、域名代购:http://shop63846532.taobao.com/

发表于 2018-12-10 12:53:03 | 显示全部楼层

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
g++ : Depends: g++-7 (>= 7.3.0-12~) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
。。。。。。
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
build-essential : Depends: g++ (>= 4:7.2) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
。。。。。。
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
g++ : Depends: g++-7 (>= 7.3.0-12~) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
。。。。。。
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libncurses5-dev : Depends: libtinfo5 (= 6.1-1ubuntu1) but 6.1-1ubuntu1.18.04 is to be installed
                   Depends: libncurses5 (= 6.1-1ubuntu1) but 6.1-1ubuntu1.18.04 is to be installed
                   Depends: libtinfo-dev (= 6.1-1ubuntu1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
。。。。。。。
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libssl-dev : Depends: libssl1.1 (= 1.1.0g-2ubuntu4) but 1.1.0g-2ubuntu4.1 is to be installed
E: Unable to correct problems, you have held broken packages.
。。。。The following information may help to resolve the situation:

The following packages have unmet dependencies:
libglib2.0-dev : Depends: libglib2.0-0 (= 2.56.1-2ubuntu1) but 2.56.3-0ubuntu0.18.04.1 is to be installed
                  Depends: libglib2.0-bin (= 2.56.1-2ubuntu1)
E: Unable to correct problems, you have held broken packages.
。。。。。
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libpng-dev : Depends: libpng16-16 (= 1.6.34-1) but 1.6.34-1ubuntu0.18.04.1 is to be installed
E: Unable to correct problems, you have held broken packages.
。。。。。。
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libxml2-dev : Depends: libicu-dev but it is not going to be installed
               Depends: libxml2 (= 2.9.4+dfsg1-6.1ubuntu1) but 2.9.4+dfsg1-6.1ubuntu1.2 is to be installed
E: Unable to correct problems, you have held broken packages.
Reading package lists...
。。。。。。
The following packages have unmet dependencies:
libcurl4-gnutls-dev : Depends: libcurl3-gnutls (= 7.58.0-2ubuntu3.1) but 7.58.0-2ubuntu3.5 is to be installed
E: Unable to correct problems, you have held broken packages.
。。。。。。
The following packages have unmet dependencies:
libcurl4-openssl-dev : Depends: libcurl4 (= 7.58.0-2ubuntu3.1) but 7.58.0-2ubuntu3.5 is to be installed
E: Unable to correct problems, you have held broken packages.

等等非常多的软件包都有存在依赖关系混乱有可能之前设置源的时候不是系统对应的版本安装过,可以使用aptitude install 软件包名字 按提示进行修复

美国VPS、VPN、域名代购:http://shop63846532.taobao.com/

您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2019-6-20 04:44 , Processed in 0.051699 second(s), 27 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表