VPS侦探论坛

 找回密码
 注册
搜索
热搜: pathinfo
查看: 478|回复: 7

lnmp 1.4 版本升级 php,只是下载了包,并没有安装,不清楚什么情况?

[复制链接]
发表于 2018-12-22 17:54:01 | 显示全部楼层 |阅读模式

再次 ./upgrade.sh php 输入版本号后:

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org/
 楼主| 发表于 2018-12-22 18:23:12 | 显示全部楼层

难道 lnmp1.4不支持 7.2及以上吗
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
 楼主| 发表于 2018-12-22 18:26:23 | 显示全部楼层


https://bbs.vpser.net/viewthread.php?tid=16862&highlight=lnmp1.4%2Bphp7.2

看到了这个解决7.2的问题,,那么7.3的如何安装呢/
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
 楼主| 发表于 2018-12-22 18:29:55 | 显示全部楼层

这个是升级 7.3 的日志:
configure: error: Please reinstall the libzip distribution
make: *** No targets specified and no makefile found.  Stop.
make: *** No rule to make target `install'.  Stop.
Copy new php configure file...
Modify php.ini......
include/upgrade_php.sh: line 104: pear: command not found
include/upgrade_php.sh: line 105: pecl: command not found
include/php.sh: line 29: php: command not found
curl: (23) Failed writing body (0 != 16133)
Install ZendGuardLoader for PHP 7...
unavailable now.
Write ZendGuardLoader to php.ini...
Creating new php-fpm configure file...
Copy php-fpm init.d file...
cp: cannot stat `/home/dev/lnmp1.4/src/php-7.3.0/sapi/fpm/init.d.php-fpm': No such file or directory
chmod: cannot access `/etc/init.d/php-fpm': No such file or directory
+-------------------------------------------+
|    Manager for LNMP, Written by Licess    |
+-------------------------------------------+
|              https://lnmp.org             |
+-------------------------------------------+
Starting LNMP...
Starting nginx...  done
/bin/lnmp: line 27: /etc/init.d/php-fpm: No such file or directory
Starting php-fpm  done
======== upgrade php failed ======
upgrade php log: /root/upgrade_lnmp_php.log
You upload upgrade_lnmp_php.log to LNMP Forum for help.
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2018-12-23 10:56:31 | 显示全部楼层

1.5都不支持php 7.3,更不用说1.4了,等过段时间1.6测试版发布,用1.6的升级脚本升级php7.3

美国VPS、VPN、域名代购:http://shop63846532.taobao.com/

 楼主| 发表于 2018-12-23 14:36:47 | 显示全部楼层



就是说,可以不升级 lnmp1.4 至 1.6 版本,但是可以直接使用 1.6 版本的升级脚本来升级 php 7.2 到 7.3 吗?

美国VPS、VPN、域名代购:http://shop63846532.taobao.com/

 楼主| 发表于 2018-12-23 14:37:18 | 显示全部楼层

回复 5# 的帖子


就是说,可以不升级 lnmp1.4 至 1.6 版本,但是可以直接使用 1.6 版本的升级脚本来升级 php 7.2 到 7.3 吗?
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org/
发表于 2018-12-23 19:05:14 | 显示全部楼层

回复 7# 的帖子


1.5及之前的版本可以使用1.6的升级脚本通用
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org/
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2019-4-25 18:58 , Processed in 0.048888 second(s), 27 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表