VPS侦探论坛

 找回密码
 注册
搜索
查看: 332|回复: 3

安装LNMP失败

[复制链接]
发表于 2018-12-26 19:53:49 | 显示全部楼层 |阅读模式

centos 6.5  64位安装
nginx-1.14.1
mysql-5.5.60
php-5.6.36

错误

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2018-12-27 10:31:22 | 显示全部楼层



--> Finished Dependency Resolution
Error:  Multilib version problems found. This often means that the root
       cause is something else and multilib version checking is just
       pointing out that there is a problem. Eg.:
      
         1. You have an upgrade for libxml2 which is missing some
            dependency that another package requires. Yum is trying to
            solve this by installing an older version of libxml2 of the
            different architecture. If you exclude the bad architecture
            yum will tell you what the root cause is (which package
            requires what). You can try redoing the upgrade with
            --exclude libxml2.otherarch ... this should give you an error
            message showing the root cause of the problem.
      
         2. You have multiple architectures of libxml2 installed, but
            yum can only see an upgrade for one of those arcitectures.
            If you don't want/need both architectures anymore then you
            can remove the one with the missing update and everything
            will work.
      
         3. You have duplicate versions of libxml2 installed already.
            You can use "yum check" to get yum show these errors.
      
       ...you can also use --setopt=protected_multilib=false to remove
       this checking, however this is almost never the correct thing to
       do as something else is very likely to go wrong (often causing
       much more problems).
      
       Protected multilib versions: libxml2-2.7.6-21.el6_8.1.i686 != libxml2-2.9.4-2.0.cf.fc6.x86_64
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
。。。。。。
checking for XSL support... yes
configure: error: xslt-config not found. Please reinstall the libxslt >= 1.1.0 distribution

可以尝试执行 yum install libxml2 libxml2-devel libxslt libxslt-devel --setopt=protected_multilib=false 修复一下再试试

美国VPS、VPN、域名代购:http://shop63846532.taobao.com/

 楼主| 发表于 2018-12-27 12:37:35 | 显示全部楼层

搞定了,第一次按原的上面方法不成功,后来我发现组件的版本不兼容是因为我的系统有添加新的源,所以出现了多个版本的libxml,
果断卸载此yum源 rpm -e city-fan.org-release   重装OK
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org/
 楼主| 发表于 2018-12-27 12:38:11 | 显示全部楼层



谢谢,军哥。。。。。。。
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2019-6-20 04:54 , Processed in 0.044572 second(s), 27 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表