VPS侦探论坛

 找回密码
 注册
查看: 207|回复: 6

centos8 lnmp1.7 php7.4 安装失败

[复制链接]
发表于 2020-4-13 15:50:44 | 显示全部楼层 |阅读模式



  1. checking whether to enable multibyte string support... yes
  2. checking whether to enable multibyte regex support (requires oniguruma)... yes
  3. checking for oniguruma... no
  4. configure: error: Package requirements (oniguruma) were not met:

  5. Package 'oniguruma', required by 'virtual:world', not found

  6. Consider adjusting the PKG_CONFIG_PATH environment variable if you
  7. installed software in a non-standard prefix.

  8. Alternatively, you may set the environment variables ONIG_CFLAGS
  9. and ONIG_LIBS to avoid the need to call pkg-config.
  10. See the pkg-config man page for more details.
  11. make: *** No targets specified and no makefile found.  Stop.
  12. make: *** No targets specified and no makefile found.  Stop.
  13. make: *** No rule to make target 'install'.  Stop.
  14. Copy new php configure file...
  15. Modify php.ini......
复制代码


美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
 楼主| 发表于 2020-4-13 16:31:31 | 显示全部楼层


  1. //腾讯云 centos8

  2. [root@VM_0_16_centos ~]# yum -y install oniguruma-devel
  3. Last metadata expiration check: 0:09:28 ago on Mon 13 Apr 2020 04:18:52 PM CST.
  4. No match for argument: oniguruma-devel
复制代码

  1. [root@VM_0_16_centos ~]# dnf --enablerepo=PowerTools install rpcgen -y
  2. Error: Unknown repo: 'PowerTools'
  3. [root@VM_0_16_centos ~]# dnf --enablerepo=PowerTools install oniguruma-devel -y
  4. Error: Unknown repo: 'PowerTools'
复制代码
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
发表于 2020-4-13 17:36:36 | 显示全部楼层



之前安装依赖包肯定报错了,按要求上传完整日志看一下
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
 楼主| 发表于 2020-4-13 17:59:25 | 显示全部楼层



  1. Last metadata expiration check: 0:00:41 ago on Mon 13 Apr 2020 04:18:52 PM CST.
  2. No match for argument: oniguruma-devel
  3. Error: Unable to find a match
  4. Last metadata expiration check: 0:00:44 ago on Mon 13 Apr 2020 04:18:52 PM CST.
  5. Package nss available, but not installed.
  6. No match for argument: nss
  7. Error: No packages marked for upgrade.
  8. Error: Unknown repo: 'PowerTools'
  9. Error: Unknown repo: 'PowerTools'
  10. [+] Downloading files...
  11. Notice: libiconv-1.15.tar.gz not found!!!download now...
复制代码

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
 楼主| 发表于 2020-4-13 18:01:12 | 显示全部楼层

  1. [root@VM_0_16_centos ~]# cat /proc/version
  2. Linux version 4.18.0-80.el8.x86_64 (mockbuild@kbuilder.bsys.centos.org) (gcc version 8.2.1 20180905 (Red Hat 8.2.1-3) (GCC)) #1 SMP Tue Jun 4 09:19:46 UTC 2019
  3. [root@VM_0_16_centos ~]# uname -a
  4. Linux VM_0_16_centos 4.18.0-80.el8.x86_64 #1 SMP Tue Jun 4 09:19:46 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
  5. [root@VM_0_16_centos ~]# cat /etc/redhat-release
  6. CentOS Linux release 8.0.1905 (Core)
  7. [root@VM_0_16_centos ~]#
复制代码

美国VPS、VPN、域名代购:http://shop63846532.taobao.com/

发表于 2020-4-13 20:07:10 | 显示全部楼层


可能你的vps服务商精简掉了PowerTool源,你 cat /etc/yum.repos.d/CentOS-PowerTools.repo 看一下,是否存在,不存在的话
可以自己创建 /etc/yum.repos.d/CentOS-PowerTools.repo  文件,添加如下内容:
  1. # CentOS-PowerTools.repo
  2. #
  3. # The mirror system uses the connecting IP address of the client and the
  4. # update status of each mirror to pick mirrors that are updated to and
  5. # geographically close to the client.  You should use this for CentOS updates
  6. # unless you are manually picking other mirrors.
  7. #
  8. # If the mirrorlist= does not work for you, as a fall back you can try the
  9. # remarked out baseurl= line instead.
  10. #
  11. #

  12. [PowerTools]
  13. name=CentOS-$releasever - PowerTools
  14. mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=PowerTools&infra=$infra
  15. #baseurl=http://mirror.centos.org/$contentdir/$releasever/PowerTools/$basearch/os/
  16. gpgcheck=1
  17. enabled=0
  18. gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-centosofficial
复制代码

然后 dnf --enablerepo=PowerTools install oniguruma-devel -y 试一下
 楼主| 发表于 2020-4-13 20:48:02 | 显示全部楼层

licess 发表于 2020-4-13 20:07
可能你的vps服务商精简掉了PowerTool源,你 cat /etc/yum.repos.d/CentOS-PowerTools.repo 看一下,是否 ...

确实是没这个文件。
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2020-5-31 14:34 , Processed in 0.050396 second(s), 27 queries .

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表