VPS侦探论坛

 找回密码
 注册
查看: 298|回复: 3

如何更新ICU版本-wordpress-AMP

[复制链接]
发表于 2020-5-22 14:18:18 | 显示全部楼层 |阅读模式




WordPress  安装了AMP 插件, 后台提示ICU版本过低` 如何更新?






本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2020-5-23 14:55:35 | 显示全部楼层


icu版本是依赖系统上icu的,你系统上低所以php上就低,看你这版本估计可能是centos 6
需要卸载掉系统上自带的libicu-devel,并手动下载新的icu4c源码,编译安装到/usr 目录
然后修改 include/upgrade_php.sh 将里面的libicu-devel 包删掉,再升级php
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
 楼主| 发表于 2020-5-24 15:43:34 | 显示全部楼层



licess 发表于 2020-5-23 14:55
icu版本是依赖系统上icu的,你系统上低所以php上就低,看你这版本估计可能是centos 6
需要卸载掉系统上自带 ...

按照料神sam 教程在Linode 安装的是centos 6.8 系统, 如何升级到centos 8 系统?  升级centos 对现在的网站会有影响嘛?
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2020-5-25 08:16:00 | 显示全部楼层



luis 发表于 2020-5-24 15:43
按照料神sam 教程在Linode 安装的是centos 6.8 系统, 如何升级到centos 8 系统?  升级centos 对现在的网 ...

升级过程网站肯定会中断
centos的升级比较麻烦,而且失败率高,各种问题,你用的linode建议开一台新的,搭建好环境并迁移网站和数据过去,然后swap ip交换ip,然后确保网站正常运行后删除原来的

Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2020-12-3 19:41 , Processed in 0.091910 second(s), 27 queries .

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表