VPS侦探论坛

 找回密码
 注册
查看: 218|回复: 3

1.7在 Aliyun Linux release 2.1903 LTS下PHP安装失败

[复制链接]
发表于 2020-6-23 18:00:26 | 显示全部楼层 |阅读模式



1.7在 Aliyun Linux release 2.1903 LTS下PHP安装失败

日志在附件,麻烦帮忙看一下,谢谢


本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
 楼主| 发表于 2020-6-23 18:24:43 | 显示全部楼层


是安装的php7.4
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
发表于 2020-6-23 20:11:47 | 显示全部楼层



aliyun linux不如centos好用,建议换centos、debian等常见linux发行版
非用aliyun linux的话可以编辑 include/init.sh 查找 if echo "${CentOS_Version}" | grep -Eqi "^7"  || echo "${RHEL_Version}" | grep -Eqi "^7"; then 替换为 if echo "${Aliyun_Version}" | grep -Eqi "^2"  || echo "${RHEL_Version}" | grep -Eqi "^7"; then 保存,然后再重新安装
或选php 7.3版本就行了
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
 楼主| 发表于 2020-6-24 09:09:31 | 显示全部楼层



licess 发表于 2020-6-23 20:11
aliyun linux不如centos好用,建议换centos、debian等常见linux发行版
非用aliyun linux的话可以编辑 inclu ...

谢谢老大,已经换为centos 8.1了
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2020-9-25 20:11 , Processed in 0.109918 second(s), 27 queries .

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表