VPS侦探论坛

 找回密码
 注册
查看: 228|回复: 1

lnmp1.7安装php7.2出错

[复制链接]
发表于 2020-6-26 23:30:41 | 显示全部楼层 |阅读模式



树莓派4b 1gbram
raspbian Debian10 32bit

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2020-6-27 10:27:26 | 显示全部楼层


正在读取软件包列表...
W: 目标 Sources (main/source/Sources) 在 /etc/apt/sources.list:5 和 /etc/apt/sources.list.d/raspi.list:5 中被配置了多次
W: 目标 Packages (main/binary-armhf/Packages) 在 /etc/apt/sources.list:4 和 /etc/apt/sources.list.d/raspi.list:4 中被配置了多次
W: 目标 Packages (main/binary-all/Packages) 在 /etc/apt/sources.list:4 和 /etc/apt/sources.list.d/raspi.list:4 中被配置了多次
W: 目标 Translations (main/i18n/Translation-zh_CN) 在 /etc/apt/sources.list:4 和 /etc/apt/sources.list.d/raspi.list:4 中被配置了多次
W: 目标 Translations (main/i18n/Translation-zh) 在 /etc/apt/sources.list:4 和 /etc/apt/sources.list.d/raspi.list:4 中被配置了多次
W: 目标 Translations (main/i18n/Translation-zh_CN.UTF-8) 在 /etc/apt/sources.list:4 和 /etc/apt/sources.list.d/raspi.list:4 中被配置了多次
W: 目标 Translations (main/i18n/Translation-en) 在 /etc/apt/sources.list:4 和 /etc/apt/sources.list.d/raspi.list:4 中被配置了多次
W: 目标 Sources (main/source/Sources) 在 /etc/apt/sources.list:5 和 /etc/apt/sources.list.d/raspi.list:5 中被配置了多次
W: 目标 Packages (main/binary-armhf/Packages) 在 /etc/apt/sources.list:4 和 /etc/apt/sources.list.d/raspi.list:4 中被配置了多次
W: 目标 Packages (main/binary-all/Packages) 在 /etc/apt/sources.list:4 和 /etc/apt/sources.list.d/raspi.list:4 中被配置了多次
W: 目标 Translations (main/i18n/Translation-zh_CN) 在 /etc/apt/sources.list:4 和 /etc/apt/sources.list.d/raspi.list:4 中被配置了多次
W: 目标 Translations (main/i18n/Translation-zh) 在 /etc/apt/sources.list:4 和 /etc/apt/sources.list.d/raspi.list:4 中被配置了多次
W: 目标 Translations (main/i18n/Translation-zh_CN.UTF-8) 在 /etc/apt/sources.list:4 和 /etc/apt/sources.list.d/raspi.list:4 中被配置了多次
W: 目标 Translations (main/i18n/Translation-en) 在 /etc/apt/sources.list:4 和 /etc/apt/sources.list.d/raspi.list:4 中被配置了多次

...
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
libc-client2007e-dev : 依赖: libpam0g-dev 但是它将不会被安装
                        依赖: libssl-dev 但是它将不会被安装
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。

有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
libc-client2007e-dev : 依赖: libpam0g-dev 但是它将不会被安装
                        依赖: libssl-dev 但是它将不会被安装
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。

可能你软件原上设置有问题,导致部分依赖包无法正常安装,首先调整好系统源,然后可以尝试aptitude install 前面提示的软件包名 如果正常修复安装成功,再重新安装lnmp就行
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2020-9-25 20:20 , Processed in 0.050388 second(s), 27 queries .

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表