VPS侦探论坛

 找回密码
 注册
查看: 151|回复: 1

php7.4下无法安装ioncube

[复制链接]
发表于 2020-8-13 01:09:01 | 显示全部楼层 |阅读模式



php7.4,安装ioncube时提示:Do not support current PHP version or PHP error!
查看ioncube.sh:
    if echo "${Cur_PHP_Version}" | grep -Eqi '^5.2.'; then
       zend_ext="/usr/local/ioncube/ioncube_loader_lin_5.2.so"
    elif echo "${Cur_PHP_Version}" | grep -Eqi '^5.3.'; then
       zend_ext="/usr/local/ioncube/ioncube_loader_lin_5.3.so"
    elif echo "${Cur_PHP_Version}" | grep -Eqi '^5.4.'; then
       zend_ext="/usr/local/ioncube/ioncube_loader_lin_5.4.so"
    elif echo "${Cur_PHP_Version}" | grep -Eqi '^5.5.'; then
       zend_ext="/usr/local/ioncube/ioncube_loader_lin_5.5.so"
    elif echo "${Cur_PHP_Version}" | grep -Eqi '^5.6.'; then
       zend_ext="/usr/local/ioncube/ioncube_loader_lin_5.6.so"
    elif echo "${Cur_PHP_Version}" | grep -Eqi '^7.0.'; then
       zend_ext="/usr/local/ioncube/ioncube_loader_lin_7.0.so"
    elif echo "${Cur_PHP_Version}" | grep -Eqi '^7.1.'; then
       zend_ext="/usr/local/ioncube/ioncube_loader_lin_7.1.so"
    elif echo "${Cur_PHP_Version}" | grep -Eqi '^7.2.'; then
       zend_ext="/usr/local/ioncube/ioncube_loader_lin_7.2.so"
    elif echo "${Cur_PHP_Version}" | grep -Eqi '^7.3.'; then
       zend_ext="/usr/local/ioncube/ioncube_loader_lin_7.3.so"
    else
        Echo_Red "Do not support current PHP version or PHP error!"
        exit 1
    fi

没有php7.4版本的判断,可以直接增加一个判断么:
    elif echo "${Cur_PHP_Version}" | grep -Eqi '^7.4.'; then
       zend_ext="/usr/local/ioncube/ioncube_loader_lin_7.4.so"

美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2020-8-13 08:46:16 | 显示全部楼层


1.7发布时ioncuber loader的php 7.4还没发布,所以里面没有,随便改一个都改成7.4就行了,最近我就添加上
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2020-9-27 14:04 , Processed in 0.075909 second(s), 26 queries .

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表