VPS侦探论坛

 找回密码
 注册
查看: 1136|回复: 5

PHP8 已发布,好像没法升级

[复制链接]
发表于 2020-11-26 13:05:11 | 显示全部楼层 |阅读模式



PHP8 已发布,好像没法升级
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2020-11-26 19:29:11 | 显示全部楼层


php 8目前只有rc版,没有正式版,正式版发布后会进行适配,适配了才能进行升级
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
发表于 2020-11-27 12:19:54 | 显示全部楼层



licess 发表于 2020-11-26 19:29
php 8目前只有rc版,没有正式版,正式版发布后会进行适配,适配了才能进行升级 ...

正式发布了哦 https://www.php.net/archive/2020.php
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2020-12-17 00:44:35 | 显示全部楼层



同问,现在能升级PHP8了吗
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
发表于 2020-12-17 11:00:31 | 显示全部楼层

可以在include/upgrade_php.sh 上改php 7.4的判断和include/version.sh 里php 7.4的版本号自行升级
lnmp 1.7上是不会添加php 8.0的,lnmp 1.8测试版上添加上
php 8.0在兼容性上,没做单独适配的话可能运行也存在问题,探针之类的都重新做的适配

美国VPS、VPN、域名代购:http://shop63846532.taobao.com/

发表于 2020-12-17 16:12:35 | 显示全部楼层

licess 发表于 2020-12-17 11:00
可以在include/upgrade_php.sh 上改php 7.4的判断和include/version.sh 里php 7.4的版本号自行升级
lnmp 1. ...

@licess  探针建议替换为目前最为流行的 x-prober (https://github.com/kmvan/x-prober)

还有建议添加安装 mongodb、swoole 等扩展
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2021-8-4 20:22 , Processed in 0.097271 second(s), 26 queries .

Powered by Discuz! X3.4

Copyright © 2001-2021, Tencent Cloud.

快速回复 返回顶部 返回列表