VPS侦探论坛

 找回密码
 注册
查看: 151|回复: 1

Ubuntu 16.04安装php7.2失败

[复制链接]
发表于 2020-12-31 17:31:10 | 显示全部楼层 |阅读模式



本帖最后由 506512674 于 2020-12-31 17:32 编辑

lnmp是1.5版本,想增加多版本php,结果失败
日志文件:
https://wwe.lanzous.com/i3L58jwb6qj
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2021-1-1 08:09:39 | 显示全部楼层


/root/lnmp1.5/src/php-7.2.6/ext/intl/breakiterator/codepointiterator_internal.cpp:39: undefined reference to `icu_58::BreakIterator::BreakIterator()'
/root/lnmp1.5/src/php-7.2.6/ext/intl/breakiterator/codepointiterator_internal.cpp:42: undefined reference to `utext_openUChars_58'
/root/lnmp1.5/src/php-7.2.6/ext/intl/breakiterator/codepointiterator_internal.cpp:39: undefined reference to `icu_58::BreakIterator::~BreakIterator()'
ext/intl/breakiterator/.libs/codepointiterator_internal.o: In function `PHP::CodePointBreakIterator::operator=(PHP::CodePointBreakIterator const&)':
/root/lnmp1.5/src/php-7.2.6/ext/intl/breakiterator/codepointiterator_internal.cpp:60: undefined reference to `utext_clone_58'
ext/intl/breakiterator/.libs/codepointiterator_internal.o: In function `PHP::CodePointBreakIterator::CodePointBreakIterator(PHP::CodePointBreakIterator const&)':
/root/lnmp1.5/src/php-7.2.6/ext/intl/breakiterator/codepointiterator_internal.cpp:46: undefined reference to `icu_58::BreakIterator::~BreakIterator()'
ext/intl/breakiterator/.libs/codepointiterator_internal.o: In function `PHP::CodePointBreakIterator::clone() const':
/root/lnmp1.5/src/php-7.2.6/ext/intl/breakiterator/codepointiterator_internal.cpp:95: undefined reference to `icu_58::UMemory::operator new(unsigned long)'
/root/lnmp1.5/src/php-7.2.6/ext/intl/breakiterator/codepointiterator_internal.cpp:95: undefined reference to `icu_58::UMemory::operator delete(void*)'
ext/intl/breakiterator/.libs/codepointiterator_internal.o: In function `PHP::CodePointBreakIterator::createBufferClone(void*, int&, UErrorCode&)':
/root/lnmp1.5/src/php-7.2.6/ext/intl/breakiterator/codepointiterator_internal.cpp:257: undefined reference to `icu_58::UMemory::operator new(unsigned long)'
/root/lnmp1.5/src/php-7.2.6/ext/intl/breakiterator/codepointiterator_internal.cpp:257: undefined reference to `icu_58::UMemory::operator delete(void*)'
ext/intl/breakiterator/.libs/codepointiterator_internal.o: In function `PHP::CodePointBreakIterator::getUText(UText*, UErrorCode&) const':
/root/lnmp1.5/src/php-7.2.6/ext/intl/breakiterator/codepointiterator_internal.cpp:111: undefined reference to `utext_clone_58'
ext/intl/breakiterator/.libs/codepointiterator_internal.o: In function `PHP::CodePointBreakIterator::~CodePointBreakIterator()':
/root/lnmp1.5/src/php-7.2.6/ext/intl/breakiterator/codepointiterator_internal.cpp:69: undefined reference to `icu_58::BreakIterator::~BreakIterator()'
ext/intl/breakiterator/.libs/codepointiterator_internal.o: In function `PHP::CodePointBreakIterator::~CodePointBreakIterator()':
/root/lnmp1.5/src/php-7.2.6/ext/intl/breakiterator/codepointiterator_internal.cpp:75: undefined reference to `icu_58::UMemory::operator delete(void*)'
ext/intl/breakiterator/.libs/codepointiterator_internal.o:(.data.rel.ro._ZTIN3PHP22CodePointBreakIteratorE[_ZTIN3PHP22CodePointBreakIteratorE]+0x10): undefined reference to `typeinfo for icu_58::BreakIterator'
ext/intl/breakiterator/.libs/codepointiterator_internal.o:(.data.rel.ro._ZTVN3PHP22CodePointBreakIteratorE[_ZTVN3PHP22CodePointBreakIteratorE]+0xa8): undefined reference to `icu_58::BreakIterator::getRuleStatus() const'
ext/intl/breakiterator/.libs/codepointiterator_internal.o:(.data.rel.ro._ZTVN3PHP22CodePointBreakIteratorE[_ZTVN3PHP22CodePointBreakIteratorE]+0xb0): undefined reference to `icu_58::BreakIterator::getRuleStatusVec(int*, int, UErrorCode&)'
ext/xmlrpc/libxmlrpc/.libs/encodings.o: In function `convert':
/root/lnmp1.5/src/php-7.2.6/ext/xmlrpc/libxmlrpc/encodings.c:65: undefined reference to `libiconv_open'
/root/lnmp1.5/src/php-7.2.6/ext/xmlrpc/libxmlrpc/encodings.c:73: undefined reference to `libiconv'
/root/lnmp1.5/src/php-7.2.6/ext/xmlrpc/libxmlrpc/encodings.c:93: undefined reference to `libiconv_close'
/root/lnmp1.5/src/php-7.2.6/ext/xmlrpc/libxmlrpc/encodings.c:93: undefined reference to `libiconv_close'

ubuntu 16.04对应的libicu是55.1,但是你系统上是58,说明你系统上另外安装了一个48版本的libicu导致的,也可能是通过安装其他软件安装上的
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2021-1-25 23:50 , Processed in 0.088441 second(s), 26 queries .

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表