VPS侦探论坛

 找回密码
 注册
查看: 157|回复: 1

无法使用let's encrypt自动安装证书,报错无法初始化api

[复制链接]
发表于 2021-2-15 23:05:02 | 显示全部楼层 |阅读模式



[Mon 15 Feb 2021 10:32:28 PM CST] Please refer to https://curl.haxx.se/libcurl/c/libcurl-errors.html for error code: 28
[Mon 15 Feb 2021 10:32:28 PM CST] Can not init api.
[Mon 15 Feb 2021 10:32:28 PM CST] Using CA: https://acme-v02.api.letsencrypt.org/directory
[Mon 15 Feb 2021 10:37:29 PM CST] Please refer to https://curl.haxx.se/libcurl/c/libcurl-errors.html for error code: 28
[Mon 15 Feb 2021 10:37:29 PM CST] Can not init api.
[Mon 15 Feb 2021 10:37:29 PM CST] Registering account: https://acme-v02.api.letsencrypt.org/directory
[Mon 15 Feb 2021 10:42:30 PM CST] Please refer to https://curl.haxx.se/libcurl/c/libcurl-errors.html for error code: 28
[Mon 15 Feb 2021 10:42:30 PM CST] Could not get nonce, let's try again.
[Mon 15 Feb 2021 10:46:33 PM CST] Please refer to https://curl.haxx.se/libcurl/c/libcurl-errors.html for error code: 35
[Mon 15 Feb 2021 10:46:33 PM CST] Could not get nonce, let's try again.

美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2021-2-16 09:07:21 | 显示全部楼层


error code: 28 的话是连接超时,有可能你网络连接到letsencrypt网络不畅通

error code: 35的话是SSL握手时报错,有可能系统上openssl版本问题,可以尝试在生成证书之前执行 export ACME_USE_WGET=1
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2021-3-2 21:43 , Processed in 0.047849 second(s), 26 queries .

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表