VPS侦探论坛

 找回密码
 注册
查看: 227|回复: 6

如何看到哪里出错呢 win10ubuntu 子系统安装出现的

[复制链接]
发表于 2021-2-26 18:05:04 | 显示全部楼层 |阅读模式



如何看到哪里出错呢 win10ubuntu 子系统安装出现的
lnmp1.7
log地址: https://ws28.cn/f/4t3ut65yq3s
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2021-2-27 10:12:30 | 显示全部楼层


[ 28%] Building CXX object sql/CMakeFiles/sql.dir/opt_table_elimination.cc.o
during RTL pass: vartrack
/home/lnmp1.7/src/mariadb-10.4.13/sql/opt_table_elimination.cc: In function ‘void add_module_expr(Dep_analysis_context*, Dep_module_expr**, uint, Dep_value_field*, Item*, List<Dep_value_field>*)’:
/home/lnmp1.7/src/mariadb-10.4.13/sql/opt_table_elimination.cc:1551:1: internal compiler error: Segmentation fault
1551 | }
      | ^
Please submit a full bug report,
with preprocessed source if appropriate.
See <file:///usr/share/doc/gcc-9/README.Bugs> for instructions.
make[2]: *** [sql/CMakeFiles/sql.dir/build.make:2061: sql/CMakeFiles/sql.dir/opt_table_elimination.cc.o] Error 1
make[1]: *** [CMakeFiles/Makefile2:11037: sql/CMakeFiles/sql.dir/all] Error 2


不确定什么原因
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
发表于 2021-2-28 12:27:00 | 显示全部楼层



@licess  我也是在win10 wls2 的 debian 子系统里,出现以下错误:  

System has not been booted with systemd as init system (PID 1). Can't operate.   

因为子系统没有  systemctl  导致的吗
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
 楼主| 发表于 2021-2-28 17:35:05 | 显示全部楼层



long 发表于 2021-2-28 12:27
@licess  我也是在win10 wls2 的 debian 子系统里,出现以下错误:  

System has not been booted with s ...

不知道欸,已经删了,改用xampp了,
我笔记本上的 WSL 可以安装成功 LNMP1.7
出问题的台式机,
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
发表于 2021-2-28 19:56:23 | 显示全部楼层

long 发表于 2021-2-28 12:27
@licess  我也是在win10 wls2 的 debian 子系统里,出现以下错误:  

System has not been booted with s ...

wls子系统没接触过不太了解

美国VPS、VPN、域名代购:http://shop63846532.taobao.com/

发表于 2021-3-1 12:23:03 | 显示全部楼层

@licess  上面的“wls”写错了,应该是  wsl ,   
我现在把所有脚本里 有判断 systemctl 和使用 systemctl 的地方注释掉,就可以正常跑了,     
因为在 wsl2 的 debian 系统用“command -v systemctl”判断是存在的,但它无法使用 导致报 “System has not been booted with systemd as init system (PID 1). Can't operate. ”
发表于 2021-3-2 08:46:52 | 显示全部楼层

long 发表于 2021-3-1 12:23
@licess  上面的“wls”写错了,应该是  wsl ,   
我现在把所有脚本里 有判断 systemctl 和使用 systemct ...

收到,我装个试试
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2021-4-15 13:03 , Processed in 0.057984 second(s), 26 queries .

Powered by Discuz! X3.4

Copyright © 2001-2021, Tencent Cloud.

快速回复 返回顶部 返回列表