查看: 194|回复: 1


发表于 2021-3-8 10:15:11 | 显示全部楼层 |阅读模式



您需要 登录 才可以下载或查看,没有帐号?注册

美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2021-3-8 15:41:45 | 显示全部楼层

Error: Package: glib2-devel-2.56.1-5.el7.x86_64 (base)
           Requires: glib2(x86-64) = 2.56.1-5.el7
           Installed: glib2-2.56.1-7.el7.x86_64 (@base)
               glib2(x86-64) = 2.56.1-7.el7
           Available: glib2-2.56.1-5.el7.x86_64 (base)
               glib2(x86-64) = 2.56.1-5.el7
You could try using --skip-broken to work around the problem
** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
glibc-headers-2.17-307.el7.1.x86_64 has missing requires of kernel-headers >= ('0', '2.2.1', None)
Error:  Multilib version problems found. This often means that the root
       cause is something else and multilib version checking is just
       pointing out that there is a problem. Eg.:
         1. You have an upgrade for nss which is missing some
            dependency that another package requires. Yum is trying to
            solve this by installing an older version of nss of the
            different architecture. If you exclude the bad architecture
            yum will tell you what the root cause is (which package
            requires what). You can try redoing the upgrade with
            --exclude nss.otherarch ... this should give you an error
            message showing the root cause of the problem.
         2. You have multiple architectures of nss installed, but
            yum can only see an upgrade for one of those architectures.
            If you don't want/need both architectures anymore then you
            can remove the one with the missing update and everything
            will work.
         3. You have duplicate versions of nss installed already.
            You can use "yum check" to get yum show these errors.
       ...you can also use --setopt=protected_multilib=false to remove
       this checking, however this is almost never the correct thing to
       do as something else is very likely to go wrong (often causing
       much more problems).
       Protected multilib versions: nss-3.44.0-7.el7_7.i686 != nss-3.53.1-3.el7_9.x86_64
Error: Protected multilib versions: nss-softokn-freebl-3.44.0-8.el7_7.i686 != nss-softokn-freebl-3.53.1-6.el7_9.x86_64
Error: Protected multilib versions: nss-util-3.44.0-4.el7_7.i686 != nss-util-3.53.1-1.el7_9.x86_64
Error: Protected multilib versions: nspr-4.21.0-1.el7.i686 != nspr-4.25.0-2.el7_9.x86_64
Error: Protected multilib versions: libcurl-7.29.0-57.el7_8.1.i686 != libcurl-7.29.0-59.el7.x86_64
Error: Protected multilib versions: nss-softokn-3.44.0-8.el7_7.i686 != nss-softokn-3.53.1-6.el7_9.x86_64

您需要登录后才可以回帖 登录 | 注册


小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2021-4-15 12:41 , Processed in 0.051306 second(s), 27 queries .

Powered by Discuz! X3.4

Copyright © 2001-2021, Tencent Cloud.

快速回复 返回顶部 返回列表