VPS侦探论坛

 找回密码
 注册
查看: 119|回复: 3

lnmp1.8 php7.3更新php7.4失败是什么问题

[复制链接]
发表于 2021-6-2 09:41:31 | 显示全部楼层 |阅读模式






本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2021-6-2 19:19:03 | 显示全部楼层


[qutoe]/usr/bin/ld: warning: libcrypto.so.1.1, needed by /usr/lib/gcc/x86_64-redhat-linux/4.8.5/../../../../lib64/libssl.so, may conflict with libcrypto.so.10
/usr/bin/ld: warning: libcrypto.so.1.1, needed by /usr/lib/gcc/x86_64-redhat-linux/4.8.5/../../../../lib64/libssl.so, may conflict with libcrypto.so.10
/usr/bin/ld: warning: libcrypto.so.1.1, needed by /usr/lib/gcc/x86_64-redhat-linux/4.8.5/../../../../lib64/libssl.so, may conflict with libcrypto.so.10
/usr/bin/ld: ext/openssl/.libs/openssl.o: undefined reference to symbol 'BN_is_zero@@OPENSSL_1_1_0'
//usr/lib64/libcrypto.so.1.1: error adding symbols: DSO missing from command line[/quote]
你系统上的openssl自行升级,而且升级的可能有问题导致的
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
 楼主| 发表于 2021-6-2 19:23:14 | 显示全部楼层



本帖最后由 ww82ke 于 2021-6-2 19:24 编辑
licess 发表于 2021-6-2 19:19
[qutoe]/usr/bin/ld: warning: libcrypto.so.1.1, needed by /usr/lib/gcc/x86_64-redhat-linux/4.8.5/../. ...

需要升级到什么版本号?现在是
OpenSSL 1.1.1k  25 Mar 2021,是最新版本了
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2021-6-3 09:49:59 | 显示全部楼层



ww82ke 发表于 2021-6-2 19:23
需要升级到什么版本号?现在是
OpenSSL 1.1.1k  25 Mar 2021,是最新版本了

php 7.4是支持openssl 1.1.1的
前面说了可能是你升级的步骤可能有问题,而且php日志上显示你用的openssl 1.1.0
你找找看是否安装了多个openssl,还有你openssl升级步骤发一下我看一下
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2021-6-18 12:41 , Processed in 0.051899 second(s), 27 queries .

Powered by Discuz! X3.4

Copyright © 2001-2021, Tencent Cloud.

快速回复 返回顶部 返回列表