VPS侦探论坛

 找回密码
 注册
查看: 361|回复: 3

CENTOS7.3 64位安装lnmp1.8失败

[复制链接]
发表于 2021-8-11 13:27:09 | 显示全部楼层 |阅读模式



用的是离线安装包,本地源。

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2021-8-11 19:14:29 | 显示全部楼层


已加载插件:fastestmirror
Loading mirror speeds from cached hostfile
正在解决依赖关系
--> 正在检查事务
---> 软件包 gcc-c++.x86_64.0.4.8.5-11.el7 将被 安装
--> 正在处理依赖关系 libstdc++-devel = 4.8.5-11.el7,它被软件包 gcc-c++-4.8.5-11.el7.x86_64 需要
--> 正在处理依赖关系 gcc = 4.8.5-11.el7,它被软件包 gcc-c++-4.8.5-11.el7.x86_64 需要
--> 正在检查事务
---> 软件包 gcc-c++.x86_64.0.4.8.5-11.el7 将被 安装
--> 正在处理依赖关系 gcc = 4.8.5-11.el7,它被软件包 gcc-c++-4.8.5-11.el7.x86_64 需要
---> 软件包 libstdc++-devel.x86_64.0.4.8.5-11.el7 将被 安装
--> 解决依赖关系完成
閿欒锛氳蒋浠跺寘锛歡cc-c++-4.8.5-11.el7.x86_64 (local-media)
          闇€瑕侊細gcc = 4.8.5-11.el7
          宸插畨瑁? gcc-4.8.5-39.el7.x86_64 (@base7)
              gcc = 4.8.2-16.el7
              gcc = 4.8.5-39.el7
          鍙敤: gcc-4.8.5-11.el7.x86_64 (local-media)
              gcc = 4.8.5-11.el7
              gcc = 4.8.2-16.el7
您可以尝试添加 --skip-broken 选项来解决该问题


。。。。。。。。
---> 软件包 xorg-x11-proto-devel.noarch.0.7.7-13.el7 将被 安装
--> 正在检查事务
---> 软件包 fontconfig-devel.x86_64.0.2.10.95-10.el7 将被 安装
--> 正在处理依赖关系 fontconfig(x86-64) = 2.10.95-10.el7,它被软件包 fontconfig-devel-2.10.95-10.el7.x86_64 需要
---> 软件包 glibc.i686.0.2.17-157.el7 将被 安装
--> 正在处理依赖关系 glibc-common = 2.17-157.el7,它被软件包 glibc-2.17-157.el7.i686 需要
--> 正在处理依赖关系 libfreebl3.so(NSSRAWHASH_3.12.3),它被软件包 glibc-2.17-157.el7.i686 需要
--> 正在处理依赖关系 libfreebl3.so,它被软件包 glibc-2.17-157.el7.i686 需要
---> 软件包 libXau-devel.x86_64.0.1.0.8-2.1.el7 将被 安装
---> 软件包 libjpeg-turbo-devel.x86_64.0.1.2.90-5.el7 将被 安装
--> 正在处理依赖关系 libjpeg-turbo(x86-64) = 1.2.90-5.el7,它被软件包 libjpeg-turbo-devel-1.2.90-5.el7.x86_64 需要
---> 软件包 libxcb.i686.0.1.11-4.el7 将被 安装
--> 正在处理依赖关系 libXau.so.6,它被软件包 libxcb-1.11-4.el7.i686 需要
--> 正在检查事务
---> 软件包 fontconfig-devel.x86_64.0.2.10.95-10.el7 将被 安装
--> 正在处理依赖关系 fontconfig(x86-64) = 2.10.95-10.el7,它被软件包 fontconfig-devel-2.10.95-10.el7.x86_64 需要
---> 软件包 glibc.i686.0.2.17-157.el7 将被 安装
--> 正在处理依赖关系 glibc-common = 2.17-157.el7,它被软件包 glibc-2.17-157.el7.i686 需要
---> 软件包 libXau.i686.0.1.0.8-2.1.el7 将被 安装
---> 软件包 libjpeg-turbo-devel.x86_64.0.1.2.90-5.el7 将被 安装
--> 正在处理依赖关系 libjpeg-turbo(x86-64) = 1.2.90-5.el7,它被软件包 libjpeg-turbo-devel-1.2.90-5.el7.x86_64 需要
---> 软件包 nss-softokn-freebl.i686.0.3.16.2.3-14.4.el7 将被 安装
--> 解决依赖关系完成
閿欒锛氳蒋浠跺寘锛歠ontconfig-devel-2.10.95-10.el7.x86_64 (local-media)
          闇€瑕侊細fontconfig(x86-64) = 2.10.95-10.el7
          宸插畨瑁? fontconfig-2.13.0-4.3.el7.x86_64 (@base7)
              fontconfig(x86-64) = 2.13.0-4.3.el7
          鍙敤: fontconfig-2.10.95-10.el7.x86_64 (local-media)
              fontconfig(x86-64) = 2.10.95-10.el7
閿欒锛氳蒋浠跺寘锛歭ibjpeg-turbo-devel-1.2.90-5.el7.x86_64 (local-media)
          闇€瑕侊細libjpeg-turbo(x86-64) = 1.2.90-5.el7
          宸插畨瑁? libjpeg-turbo-1.2.90-8.el7.x86_64 (@base7)
              libjpeg-turbo(x86-64) = 1.2.90-8.el7
          鍙敤: libjpeg-turbo-1.2.90-5.el7.x86_64 (local-media)
              libjpeg-turbo(x86-64) = 1.2.90-5.el7
閿欒锛氳蒋浠跺寘锛歡libc-2.17-157.el7.i686 (local-media)
          闇€瑕侊細glibc-common = 2.17-157.el7
          宸插畨瑁? glibc-common-2.17-292.el7.x86_64 (@base7)
              glibc-common = 2.17-292.el7
          鍙敤: glibc-common-2.17-157.el7.x86_64 (local-media)
              glibc-common = 2.17-157.el7
您可以尝试添加 --skip-broken 选项来解决该问题
** 发现 1 个已存在的 RPM 数据库问题, 'yum check' 输出如下:

你这系统上很多个软件包依赖存在问题,需要使用光盘源里的正确软件包进行重装

如果要离线安装,需要自行设置好完整的光盘源为本地源,并且添加离线安装参数

Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
 楼主| 发表于 2021-8-11 19:20:59 | 显示全部楼层



licess 发表于 2021-8-11 19:14
你这系统上很多个软件包依赖存在问题,需要使用光盘源里的正确软件包进行重装

如果要离线安装,需要自行 ...

挂载的光盘镜像为CentOS-7-x86_64-Everything-1611.iso,/etc/yum.reppos.d/Centos-Media.repo内容为:
[local-media]
name=CentOS-$releasever - Media
baseurl=file:///mnt/dvd/
gpgcheck=0
enabled=1

安装命令是:CheckMirror=n ./install.sh lnmp。
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2021-8-12 08:42:00 | 显示全部楼层



gonia119 发表于 2021-8-11 19:20
挂载的光盘镜像为CentOS-7-x86_64-Everything-1611.iso,/etc/yum.reppos.d/Centos-Media.repo内容为:
[ ...
你这系统上很多个软件包依赖存在问题,需要使用光盘源里的正确软件包进行重装

你这系统肯定在之前有设置了一个base7的源安装了其他版本的依赖包导致的,你得用光盘里的rpm包安装替换掉base7的包才行,所有有问题的包
最简单的方法重装
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2021-9-23 20:47 , Processed in 0.050739 second(s), 27 queries .

Powered by Discuz! X3.4

Copyright © 2001-2021, Tencent Cloud.

快速回复 返回顶部 返回列表