打印

http访问变成下载,Https正常;WordPress后台首页、更新页、插件页502,其他正常

http访问变成下载,Https正常;WordPress后台首页、更新页、插件页502,其他正常

军哥你好。我来请教两个问题。1、http访问变成下载,https正常
我反复用脚本生成nginx.conf文件并且vi进去检查,没有发现配置问题。但是现在wordpress的index.php无法正常打开,http访问时变成“下载”,其内容就是Index.php的内容。但是https又是正常的。
网站地址:https://xiyuemu.me/  http://xiyuemu.me/

2、wordpress后台首页、更新页、插件页502,其他正常
我的系统环境是ubuntu18.04,lnmp1.5,wordpress5.0.2,PHP5.6。其他参数可以访问http://root.xiyuemu.me/ 查看探针。
我现在是能够访问前台和登录页,登录页能正常反应,但是获取登录态后进入后台首页general-settings.php 和 update.php等就报502错误,其他如post-new.php就可以打开。
网上搜索,说是这几个页面都要访问WP官方服务器获取更新,但是提供的解决方案都不匹配。譬如大多数说这是centos6.0的问题。
论坛置顶帖子第15条中提出的方案是mv /usr/lib64/libsqlite3.so.0.8.6。但我的系统目录里没有这个文件,其他前缀名相同的文件我不敢乱动。

3、https访问网页,第一次总是报502,要刷新才能打开
尽管https可以访问,但是第一次打开网页总是502错误,要刷新才能打开。

TOP

不好意思,报告一下。第一个问题,发现是我很愚蠢地在用vi编辑conf的时候,不小心在关键位置误按了#号,正好注释掉了include php-enable.conf这一行。修复这个地方后,似乎第三个问题也不存在了。目前还在思考第二个问题。

TOP

问题越来越复杂。我已经被搞糊涂了。现在发现三个问题全都还在。并且在不同浏览器下表现不同。我现在开了强制301重定向。
chrome浏览器:http访问变成下载wordpress/index.php的文本,刷新只会重新下载,没有别的反应;https第一次访问报502,刷新后正常
edge浏览器:http访问显示为wordpress/index.php的文本(但不是下载,直接显示),刷新后重定向到https,第一次报502,再刷新后正常
IE浏览器:全都正常。http第一次访问就自动重定向到https,并且正常打开。

TOP

目前的nginx配置文件。后面还有一段https自动生成的,那段我没有改动过。
复制内容到剪贴板
代码:
server
    {
        listen 80;
        #listen [::]:80;
        server_name xiyuemu.me www.xiyuemu.me;return      301 https://xiyuemu.me$request_uri;
        index index.html index.htm index.php default.html default.htm default.php;
        root  /home/wwwroot/wordpress;

        include rewrite/wordpress.conf;
        #error_page   404   /404.html;

        # Deny access to PHP files in specific directory
        #location ~ /(wp-content|uploads|wp-includes|images)/.*\.php$ { deny all; }

        include enable-php-pathinfo.conf;

        location ~ .*\.(gif|jpg|jpeg|png|bmp|swf)$
        {
            expires      30d;
        }

        location ~ .*\.(js|css)?$
        {
            expires      12h;
        }

        location ~ /.well-known {
            allow all;
        }

        location ~ /\.
        {
            deny all;
        }

        access_log off;
    }

TOP

这个无法确定原因
浏览器清空缓存试试或使用curl命令请求看看

LNMP付费问题排查/LNMP技术支持/Paypal信用卡代付/代购VPS,域名,软件等 QQ 503228080 旺旺 lzhenbao
军哥淘宝店铺
QQ/旺旺仅提供代购及付费代维/问题解决等服务,其他不回复!LNMP相关问题请在本论坛发帖,提问前先搜索,按https://bbs.vpser.net/thread-2555-1-1.html 要求反馈问题!

TOP

重新配置环境吧,开发用 火狐开发者版的浏览器,默认F5就是深度刷新了

TOP

试试这个 https://dapiqing.cn/2018/12/25/wordpress-502/

TOP

TOP