打印

京东云 jcloud centos 无法安装LNMP一键安装包暂时解决方法

京东云 jcloud centos 无法安装LNMP一键安装包暂时解决方法

京东云自带openssl非原系统的openssl,应该是jcloud那边自编译上的,openssl版本是1.1.0b,太新太高,造成php等一些软件无法安装。
复制内容到剪贴板
代码:
[root@jdu4e00u53f7 lnmp1.4]# /usr/bin/openssl version
OpenSSL 1.1.0b  26 Sep 2016
[root@jdu4e00u53f7 lnmp1.4]# /usr/bin/openssl.bak version
OpenSSL 1.0.1e-fips 11 Feb 2013
[root@jdu4e00u53f7 lnmp1.4]# ls -l /usr/bin/openssl
lrwxrwxrwx 1 root root 22 Dec 20 14:53 /usr/bin/openssl -> /usr/local/bin/openssl
解决方法如下:
复制内容到剪贴板
代码:
rm -rf /usr/local/bin/openssl /usr/local/include/openssl/ /usr/bin/openssl
mv /usr/bin/openssl.bak /usr/bin/openssl
ldconfig
运行该命令后重启一下,重新安装lnmp就没问题了

TOP

已经向jcloud反馈,不知道后续怎样
update:据京东云反馈说是安全部门要求的,目前正在和安全部协商处理中

TOP

引用:
原帖由 licess 于 2017-4-26 16:53 发表
已经向jcloud反馈,不知道后续怎样
应该加个说明,备份的1.0.1在什么地方,如果不兼容怎么操作
另外,也要向PHP方面反馈下,是让PHP兼容openssl而不是openssl迁就PHP
不过具体就等7.1.5和7.2.0发布了,另外,可以自编译7.2来取代lnmp中的PHP么

TOP

复制内容到剪贴板
代码:
rm -rf /usr/local/bin/openssl /usr/local/include/openssl/ /usr/bin/openssl
mv /usr/bin/openssl.bak /usr/bin/opensslldconfig
这个或许可以改为以下这个,要不然以后要用到高版本openssl的时候就麻烦些
复制内容到剪贴板
代码:
mv /usr/bin/openssl /usr/bin/openssl1.1
mv /usr/local/bin/openssl /usr/local/bin/openssl1.1
mv /usr/local/include/openssl /usr/local/include/openssl1.1
mv /usr/bin/openssl.bak /usr/bin/openssl

ldconfig
[ 本帖最后由 dven 于 2017-4-26 22:10 编辑 ]

TOP

./configure --prefix=/usr/local/php --with-config-file-path=/usr/local/php/etc --with-config-file-scan-dir=/usr/local/php/conf.d --enable-fpm --with-fpm-user=www --with-fpm-group=www --enable-mysqlnd --with-mysqli=mysqlnd --with-pdo-mysql=mysqlnd --with-iconv-dir --with-freetype-dir=/usr/local/freetype --with-jpeg-dir --with-png-dir --with-zlib --with-libxml-dir=/usr --enable-xml --disable-rpath --enable-bcmath --enable-shmop --enable-sysvsem --enable-inline-optimization --with-curl --enable-mbregex --enable-mbstring --enable-intl --enable-pcntl --enable-ftp --with-gd --with-openssl --with-mhash --enable-pcntl --enable-sockets --with-xmlrpc --enable-zip --enable-soap --with-gettext --enable-fileinfo --enable-opcache --with-xsl

7.2可以用这个命令行编译吧

TOP

openssl 1.1.0本来就是个短命的版本,好像明年6、7月付就EOL了
1.0.2才是LTS,用1.0.2替代才是比较好的版本

完全等php新版的话也不太现实,php 5.5-的版本的话就完全没法用的

编译命令可以

TOP

引用:
原帖由 licess 于 2017-4-27 08:21 发表
openssl 1.1.0本来就是个短命的版本,好像明年6、7月付就EOL了
1.0.2才是LTS,用1.0.2替代才是比较好的版本

完全等php新版的话也不太现实,php 5.5-的版本的话就完全没法用的

编译命令可以 ...
那也是,不过我是早就切到7.0/7.1下开发了,所以很少考虑5.5-的问题

TOP

mysys_ssl/CMakeFiles/mysys_ssl.dir/build.make:182: recipe for target 'mysys_ssl/CMakeFiles/mysys_ssl.dir/my_md5.cc.o' failed
make[2]: *** [mysys_ssl/CMakeFiles/mysys_ssl.dir/my_md5.cc.o] Error 1
CMakeFiles/Makefile2:11657: recipe for target 'mysys_ssl/CMakeFiles/mysys_ssl.dir/all' failed
make[1]: *** [mysys_ssl/CMakeFiles/mysys_ssl.dir/all] Error 2
Makefile:160: recipe for target 'all' failed
make: *** [all] Error 2

这个问题是否也是因高版本OpenSSL引起

TOP

../../mysys_ssl/libmysys_ssl.a(my_crypt.cc.o):/root/lnmp1.4/src/mariadb-10.2.5/mysys_ssl/my_crypt.cc:41: more undefined references to `EVP_CIPHER_CTX_cleanup' follow
collect2: error: ld returned 1 exit status
unittest/mysys/CMakeFiles/aes-t.dir/build.make:105: recipe for target 'unittest/mysys/aes-t' failed
make[2]: *** [unittest/mysys/aes-t] Error 1
CMakeFiles/Makefile2:916: recipe for target 'unittest/mysys/CMakeFiles/aes-t.dir/all' failed
make[1]: *** [unittest/mysys/CMakeFiles/aes-t.dir/all] Error 2
Makefile:160: recipe for target 'all' failed

TOP

回复 9# 的帖子

有ssl,EVP_CIPHER的都是和openssl有关

TOP