打印

lnmp1.4安装失败(之前附件上传错了,还请各位重新帮忙看一下),求助!

lnmp1.4安装失败(之前附件上传错了,还请各位重新帮忙看一下),求助!


系统是Ubuntu 16.04.2 LTS 64位系统 本地环境
这是使用lnmp1.4安装时的日志,nginx,mysql都安装成功了,php选择安装的是5.3.29,安装失败;
另外,之前我使用的是lnmp1.3,只有mysql安装成功,其他的都失败了。
烦请帮忙看下是什么原因,非常感谢!

[ 本帖最后由 weblnn 于 2017-8-1 16:07 编辑 ]
附件: 您所在的用户组无法下载或查看附件

TOP

引用:
正在读取状态信息...
openssl 已经是最新版 (1.1.0f-2~ubuntu16.04.1+deb.sury.org+1)。。。。。。。
/home/lixin/soft/lnmp1.4/src/php-5.3.29/ext/openssl/openssl.c: In function ‘zif_openssl_random_pseudo_bytes’:
/home/lixin/soft/lnmp1.4/src/php-5.3.29/ext/openssl/openssl.c:5010:2: warning: ‘RAND_pseudo_bytes’ is deprecated [-Wdeprecated-declarations]
  if ((strong_result = RAND_pseudo_bytes(buffer, buffer_length)) < 0) {
  ^
In file included from /usr/include/openssl/x509_vfy.h:20:0,
                 from /usr/include/openssl/x509.h:309,
                 from /home/lixin/soft/lnmp1.4/src/php-5.3.29/ext/openssl/openssl.c:41:
/usr/include/openssl/rand.h:47:1: note: declared here
DEPRECATEDIN_1_1_0(int RAND_pseudo_bytes(unsigned char *buf, int num))
^
Makefile:588: recipe for target 'ext/openssl/openssl.lo' failed
openssl 是1.1是肯定装不上低于7.0版本的php的,等过几天测试完会出一个针对系统是openssl 1.1的完善版本

正常情况下ubuntu 16.04的话openssl 应该是1.0.2g版本的才对

按你系统版本和php版本看,属于新+旧 ,在较新版本的系统上安装php 5.3算是较老的版本是很容易出现兼容性问题的

TOP

回复 2# 的帖子

请问针对系统是openssl 1.1的完善版本出了么?或者我这边着急的话还有没有其他的解决办法?

TOP

回复 3# 的帖子

刚刚重新安装了一次,已经好了。

TOP

回复 3# 的帖子

上篇帖子后几天就已经支持了

TOP