打印

成功安装PHP多版本并运行!

成功安装PHP多版本并运行!

非常感谢军哥的lnmp1.4,非常方便。目前运行尚好。
只是有点小状况,运行http://ip/xcache,提示
XCache extension        错误        未载入        在 /usr/local/php/etc/php.ini 增加 extension=xcache.so (或 xcache.dll) (参见上面)

而左下角显示的是php7,但我明明在安装xcache时已经选择了php5的。

我查看了/usr/local/php5.3/conf.d/006-xcache.ini,发现设置只有如下:
extension = xcache.so

在xcache这个扩展上,这样的设置似乎没有问题,但是,相对memcached,之类的扩展,由于 我两个版本PHP7及PHP5均安装了memcached,005-memcached.ini的设置也都是:
extension = memcached.so

那么,会不会导致两个版本所调用的都是同一个程序?会不会出现错误?

另外,请教一下,如果需要更改其他虚机使用的PHP版本,是否只需要修改虚机conf文件下的:
include enable-php*.conf;

如果是默认的PHP7,即include enable-php.conf;    如果是PHP5,便用 include enable-php5.3.conf;

而其他地方并不需要修改?

[ 本帖最后由 yanqzh 于 2017-8-5 16:58 编辑 ]

TOP

回复 1# 的帖子

xcache的设置有30几行,只有上面哪些肯定有问题,可能自己动过或查看一下安装包 include/xcache.sh 是否修改过

多php版本使用教程官网有明确的说明 https://lnmp.org/faq/upgrade1-4.html

TOP