打印

lnmp1.4安装多版本视贝

lnmp1.4安装多版本视贝

军哥,你好
我是centos7,lnmp1.4,先安装了Php5.6,在安装php5.2.17的时候出错,详细错误见附件。

能解决吗?或如何删除现在的5.6我直接安装5.2.17
附件: 您所在的用户组无法下载或查看附件

TOP

引用:
ext/xmlrpc/libxmlrpc/encodings.o: In function `convert':
/root/lnmp1.4-full/src/php-5.2.17/ext/xmlrpc/libxmlrpc/encodings.c:73: undefined reference to `libiconv_open'
/root/lnmp1.4-full/src/php-5.2.17/ext/xmlrpc/libxmlrpc/encodings.c:81: undefined reference to `libiconv'
/root/lnmp1.4-full/src/php-5.2.17/ext/xmlrpc/libxmlrpc/encodings.c:101: undefined reference to `libiconv_close'
/root/lnmp1.4-full/src/php-5.2.17/ext/xmlrpc/libxmlrpc/encodings.c:101: undefined reference to `libiconv_close'
要安装低版本的php不要选择最新的系统,要不然基本上都是上面的错误

TOP

如何解决呢我的系统可能改不了
是重新安装lnmp1.4 还是把centos降低呢?

TOP

回复 3# 的帖子

这是兼容性问题,不降系统版本的话可以尝试将 include/multiplephp.sh 里Install_MPHP5.2 编译参数 --with-xmlrpc 去掉再重新安装php 5.2的多php版本试试看看

TOP