打印

LNMP 1.4 下如何升级 Memcached 到最新1.5.0版

LNMP 1.4 下如何升级 Memcached 到最新1.5.0版

LNMP 1.4里集成的 Memcached 好像是1.4.36版的,如何升级到最新的1.5.0版呢?

TOP

修改`lnmp1.4/include/version.sh` 里的`Memcached_Ver`的版本号为你要升级到的版本号,这里我填的是1.5.0。

将你自己需要的版本的memcached下载到 src 目录下,运行 `./addons.sh install memcached`安装编译即可。

照此方法升级依然是1.4的!

TOP

回复 2# 的帖子

还需要将 include/memcached.sh 中下面这几行
    if [ -s /usr/local/memcached/bin/memcached ]; then
        echo "Memcached already exists."
    else
和useradd -s /sbin/nologin nobody 后的 fi 删掉后进行升级memcached

TOP

回复 3# 的帖子

明白了,我现在就去试试!
谢谢军哥!

TOP

回复 3# 的帖子

OK,搞定了,哈哈!多谢了!
对了,多问一下,升级完成后,还需要恢复memcached.sh里的代码嘛?

[ 本帖最后由 明月登楼 于 2017-8-20 21:10 编辑 ]

TOP

回复 5# 的帖子

看你自己需求,如果以后还要升级memcached就保留

TOP

回复 6# 的帖子

好的,多谢军哥的回复!

TOP