打印

lnmp1.4 升级mysql到5.7.19出错

lnmp1.4 升级mysql到5.7.19出错

lnmp1.4 升级mysql5.0.12到5.7.19出错
日志见附件,请军哥帮忙看看,谢谢
附件: 您所在的用户组无法下载或查看附件

TOP

CMake Error at CMakeLists.txt:21 (CMAKE_MINIMUM_REQUIRED):
  CMake 2.8.2 or higher is required.  You are running version 2.6.4

系统自带cmake太低不满足mysql 5.7的要求
centos 6的话应该是2.8版本的,可以 yum update cmake 看一下

TOP

感谢 ,我升级了 cmake,重新升级mysql,还是不成功,但这次是不是因为我的vps内存太低了,只有512m
附件: 您所在的用户组无法下载或查看附件

TOP

回复 2# 的帖子

感谢军哥回复,我已经用你的推荐码,买了linode vps。后续有问题再跟你请教。

TOP

回复 3# 的帖子

c++: Internal error: Killed (program cc1plus)
Please submit a full bug report.
See <http://bugzilla.redhat.com/bugzilla> for instructions.
make[2]: *** [sql/CMakeFiles/sql.dir/item_geofunc.cc.o] Error 1

512MB是肯定不够用的,安装的话要1G(不含)起步

TOP