打印

已经安装了SSL证书,为什么还是http

已经安装了SSL证书,为什么还是http

使用的lnmp1.4免费的SSL,已经安装完成,但是访问网站还是http,这是什么原因呢?

TOP

你访问的http他就是http,访问的https就是https
如果想http全部跳到https 上,https://lnmp.org 上搜 301 找教程

TOP

回复 2# 的帖子

感谢军哥解答,但现在的问题是访问https网站打不开,访问http却可以

TOP

回复 3# 的帖子

信息有限,没有具体错误信息不好说

TOP

回复 4# 的帖子

使用的帝國cms,安装完成后直接访问是Http,访问正常,访问https就显示“无法访问此网站,”
conf配置如下:
复制内容到剪贴板
代码:
server
    {
        listen 80;
        #listen [::]:80;
        server_name www.xxx.net xxx.net;
        index index.html index.htm index.php default.html default.htm default.php;
        root  /home/wwwroot/xxx;

        include none.conf;
        #error_page   404   /404.html;

        # Deny access to PHP files in specific directory
        #location ~ /(wp-content|uploads|wp-includes|images)/.*\.php$ { deny all; }

        include enable-php.conf;

        location ~ .*\.(gif|jpg|jpeg|png|bmp|swf)$
        {
            expires      30d;
        }

        location ~ .*\.(js|css)?$
        {
            expires      12h;
        }

        location ~ /.well-known {
            allow all;
        }

        location ~ /\.
        {
            deny all;
        }

        access_log  /home/wwwlogs/www.xxx.net.log;
    }

server
    {
        listen 443 ssl http2;
        #listen [::]:443 ssl http2;
        server_name www.xxx.net xxx.net;
        index index.html index.htm index.php default.html default.htm default.php;
        root  /home/wwwroot/xxx;
        ssl on;
        ssl_certificate /etc/letsencrypt/live/www.xxx.net/fullchain.pem;
        ssl_certificate_key /etc/letsencrypt/live/www.xxx.net/privkey.pem;
        ssl_session_timeout 5m;
        ssl_protocols TLSv1 TLSv1.1 TLSv1.2;
        ssl_prefer_server_ciphers on;
        ssl_ciphers "此处省去:!MD5";
        ssl_session_cache builtin:1000 shared:SSL:10m;
        # openssl dhparam -out /usr/local/nginx/conf/ssl/dhparam.pem 2048
        ssl_dhparam /usr/local/nginx/conf/ssl/dhparam.pem;

        include none.conf;
        #error_page   404   /404.html;

        # Deny access to PHP files in specific directory
        #location ~ /(wp-content|uploads|wp-includes|images)/.*\.php$ { deny all; }

        include enable-php.conf;

        location ~ .*\.(gif|jpg|jpeg|png|bmp|swf)$
        {
            expires      30d;
        }

        location ~ .*\.(js|css)?$
        {
            expires      12h;
        }

        location ~ /.well-known {
            allow all;
        }

        location ~ /\.
        {
            deny all;
        }

        access_log  /home/wwwlogs/www.xxx.net.log;
    }
[ 本帖最后由 robin 于 2017-8-28 21:49 编辑 ]

TOP

回复 5# 的帖子

我要配置文件就和你说是配置文件了
环境是你vps的环境、网络环境、服务商

错误无法访问可能是本地没开443端口或者服务商防火墙没开443端口

TOP

回复 6# 的帖子

一语惊醒梦中人,还真是端口的问题,现在问题已解决,感谢,现在遇到的问题是使用如下方式配置了301,但是访问http不跳转到https
复制内容到剪贴板
代码:
server {
listen 80;
server_name www.xxx.com;
return 301 https://www.xxx.com$request_uri;
}
[ 本帖最后由 robin 于 2017-8-29 14:23 编辑 ]

TOP

回复 7# 的帖子

这个需要结合前后的配置文件才能确定

有可能的原因,更改配置文件后未重启nginx
该域名已经存在或存在多个该域名的虚拟主机配置,重启时一般都会报错,反馈必读 帖子也有测试方法

TOP