打印

本机Ubuntu17.10安装lnmp失败

本机Ubuntu17.10安装lnmp失败

Ubuntu17.10 64位系统,安装失败,附上日志求解答。因为是新装linux所以第一次失败了之后重新装过一次,然后问题依旧。lnmp lnmpa安装都不成功,安装时发现mysql服务启动失败,重复多次后成功,最后mysql,php,apache都提示的是成功nginx失败。
附件: 您所在的用户组无法下载或查看附件

TOP

正式在本本上安装前用虚拟机跑Ubuntu16.04的时候安装都是没问题的,安装到本本上的时候是Ubuntu17.10,然后就安不上了,忧伤

TOP

上传的是lnmp安装包非安装日志,无法排查

TOP

弄错了...忧伤
附件: 您所在的用户组无法下载或查看附件

TOP

回复 3# 的帖子

弄错了,重新传了一下,麻烦你了

TOP

啊哦,要不我还是放弃吧,换成16.04好了...纠结了半天17.10也不是长期支持版的,忧伤

TOP

引用:
        src/core/ngx_murmurhash.c
src/core/ngx_murmurhash.c: In function ‘ngx_murmur_hash2’:
src/core/ngx_murmurhash.c:37:11: error: this statement may fall through [-Werror=implicit-fallthrough=]
         h ^= data[2] << 16;
         ~~^~~~~~~~~~~~~~~~
src/core/ngx_murmurhash.c:38:5: note: here
     case 2:
     ^~~~
src/core/ngx_murmurhash.c:39:11: error: this statement may fall through [-Werror=implicit-fallthrough=]
         h ^= data[1] << 8;
         ~~^~~~~~~~~~~~~~~
src/core/ngx_murmurhash.c:40:5: note: here
     case 1:
     ^~~~
cc1: all warnings being treated as errors
objs/Makefile:495: recipe for target 'objs/src/core/ngx_murmurhash.o' failed
make[1]: *** [objs/src/core/ngx_murmurhash.o] Error 1
可能是因为ubuntu 17.10是gcc7版本

TOP

回复 7# 的帖子

嗯嗯,麻烦了,谢谢军哥

TOP

回复 7# 的帖子

呃...麻烦再问一下,用gcc什么版本推荐呢?

TOP

回复 9# 的帖子

gcc7太新改变好像多,nginx还未完全适配
除了ubuntu 17.10外其他支持的发行版自带的gcc应该都可以
nginx 的Mainline version应该是支持gcc7的

TOP