打印

军哥,请教一下lnmp 502报错 php-fpm

军哥,请教一下lnmp 502报错 php-fpm

listen = /tmp/php-cgi.sock
;listen = 127.0.0.1:9000



php-fpm 我设置sock,就报502
换成9000就可以
php-fpm.log日志没有报错信息,请教下这是哪里问题?
另外说明:php-fpm的listen是sock时,nginx的vhost 换成sock和9000都不行,直接报500
php-fpm的listen是9000时,nginx的vhost 换成sock和9000都可以

TOP

如果自己改过sock可能有地方没改

500的话按 https://lnmp.org 常见问题 中500部分的说明进行排查

TOP

回复 2# 的帖子

/usr/local/php/etc/php-fpm.cnf   这是个什么文件?我是lnmp1.3查看你那个文章
是不是我还有地方没改过来

我修改了
/usr/local/php/etc/php-fpm.conf(php-fpm 配置)
/usr/local/nginx/conf/vhost/*.conf(虚拟机配置)
还有其他地方要改吗?

[ 本帖最后由 test007 于 2017-11-2 09:22 编辑 ]

TOP

回复 3# 的帖子

php-fpm基本配置文件
enable-php.conf 都需要改
不了解的话建议不要自己调整

TOP