打印

lnmp 1.1 升級 PHP 至5.3.28 網站開不了, 降回又出錯

lnmp 1.1 升級 PHP 至5.3.28 網站開不了, 降回又出錯

Dear 軍哥,

lnmp 1.1 升級 PHP 至5.3.28 後部份網站開不了請問這該如何處理
從哪下手?

用 ./upgrade_php.sh 降回 5.2.17 又出錯


Starting php_fpm Zend Guard Loader requires Zend Engine API version 220090626.
The Zend Engine API version 220060519 which is installed, is outdated.

/usr/local/php/etc/php-fpm.conf:1: parser error : Start tag expected, '<' not found
[global]
^
Nov 19 21:13:22.211472 [ERROR] fpm_conf_init_main(), line 517: failed to load configuration file: failed to parse conf file
failed


請教該如何正確降回 php 5.2.17
或使用 5.3.28

願付費請軍哥處理

TOP

對了我的網站需要 Zend Optimizer
19、升级到PHP 5.3.* 版本后为什么探针显示不支持Zend Optimizer了?
答:PHP 5.3.* 之后的版本里Zend Optimizer已经改名为Zend Guard Loader,虽然探针无法查到,可以在phpinfo里看到,需要Zend Optimizer的程序也是可以正常运行的,不需要担心。


可是我網站就開不了
哪裡需要再加工嗎?

TOP

已成功降回 php 5.2.17
PHP 5.3.* 之后的版本里Zend Optimizer已经改名为Zend Guard Loader,虽然探针无法查到,可以在phpinfo里看到,需要Zend Optimizer的程序也是可以正常运行的,不需要担心。


-> 可我的站行不通


請高手指教一下該如何設定


先謝了

TOP

回复 3# 的帖子

如果已经成功降级到 php 5.2的话,里面就已经是安装好zendoptimizer的
/usr/local/php/bin/php -v 可以执行看一下

TOP