打印

centos6.4 64bit php安装失败

centos6.4 64bit php安装失败

系统:centos 6.4 64bit   安装时mini版本
附件: 您所在的用户组无法下载或查看附件

TOP

尝试安装7.0和7.1都安装不上

尝试安装7.0和7.1都安装不上

TOP

你系统上的openssl有问题

---> Package openssl.i686 0:1.0.0-27.el6 will be installed
--> Processing Dependency: libz.so.1 for package: openssl-1.0.0-27.el6.i686
--> Processing Dependency: libresolv.so.2 for package: openssl-1.0.0-27.el6.i686
--> Processing Dependency: libkrb5.so.3(krb5_3_MIT) for package: openssl-1.0.0-27.el6.i686
--> Processing Dependency: libkrb5.so.3 for package: openssl-1.0.0-27.el6.i686
--> Processing Dependency: libk5crypto.so.3(k5crypto_3_MIT) for package: openssl-1.0.0-27.el6.i686
--> Processing Dependency: libk5crypto.so.3 for package: openssl-1.0.0-27.el6.i686
--> Processing Dependency: libgssapi_krb5.so.2 for package: openssl-1.0.0-27.el6.i686
--> Processing Dependency: libdl.so.2(GLIBC_2.1) for package: openssl-1.0.0-27.el6.i686
--> Processing Dependency: libdl.so.2(GLIBC_2.0) for package: openssl-1.0.0-27.el6.i686
--> Processing Dependency: libdl.so.2 for package: openssl-1.0.0-27.el6.i686
--> Processing Dependency: libcom_err.so.2 for package: openssl-1.0.0-27.el6.i686
--> Processing Dependency: libc.so.6(GLIBC_2.7) for package: openssl-1.0.0-27.el6.i686
--> Running transaction check
---> Package glibc.i686 0:2.12-1.107.el6 will be installed
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.12-1.107.el6.i686
--> Processing Dependency: libfreebl3.so for package: glibc-2.12-1.107.el6.i686
---> Package krb5-libs.i686 0:1.10.3-10.el6 will be installed
--> Processing Dependency: libselinux.so.1 for package: krb5-libs-1.10.3-10.el6.i686
--> Processing Dependency: libkeyutils.so.1(KEYUTILS_0.3) for package: krb5-libs-1.10.3-10.el6.i686
--> Processing Dependency: libkeyutils.so.1 for package: krb5-libs-1.10.3-10.el6.i686
---> Package libcom_err.i686 0:1.41.12-14.el6 will be installed
---> Package zlib.i686 0:1.2.3-29.el6 will be installed
--> Running transaction check
---> Package keyutils-libs.i686 0:1.4-4.el6 will be installed
---> Package libselinux.i686 0:2.0.94-5.3.el6 will be installed
---> Package nss-softokn-freebl.i686 0:3.12.9-11.el6 will be installed
--> Finished Dependency Resolution
Error:  Multilib version problems found. This often means that the root
       cause is something else and multilib version checking is just
       pointing out that there is a problem. Eg.:
      
         1. You have an upgrade for openssl which is missing some
            dependency that another package requires. Yum is trying to
            solve this by installing an older version of openssl of the
            different architecture. If you exclude the bad architecture
            yum will tell you what the root cause is (which package
            requires what). You can try redoing the upgrade with
            --exclude openssl.otherarch ... this should give you an error
            message showing the root cause of the problem.
      
         2. You have multiple architectures of openssl installed, but
            yum can only see an upgrade for one of those arcitectures.
            If you don't want/need both architectures anymore then you
            can remove the one with the missing update and everything
            will work.
      
         3. You have duplicate versions of openssl installed already.
            You can use "yum check" to get yum show these errors.
      
       ...you can also use --setopt=protected_multilib=false to remove
       this checking, however this is almost never the correct thing to
       do as something else is very likely to go wrong (often causing
       much more problems).
      
       Protected multilib versions: openssl-1.0.0-27.el6.i686 != openssl-1.0.1e-48.el6_8.3.x86_64
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

可以论坛里搜索全文:Protected multilib versions 查找类似错误的处理方法

而且你设置的内网系统源都404 了
Downloading Packages:
http://10.192.3.240/centos/6.4/Packages/libevent-headers-1.4.13-4.el6.noarch.rpm: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"
Trying other mirror.
http://10.192.3.240/centos/6.4/Packages/libevent-devel-1.4.13-4.el6.x86_64.rpm: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"
Trying other mirror.
http://10.192.3.240/centos/6.4/Packages/libevent-doc-1.4.13-4.el6.noarch.rpm: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"
Trying other mirror.

LNMP付费问题排查/LNMP技术支持/Paypal信用卡代付/代购VPS,域名,软件等 QQ 503228080 旺旺 lzhenbao
军哥淘宝店铺
QQ/旺旺仅提供代购及付费代维/问题解决等服务,其他不回复!LNMP相关问题请在本论坛发帖,提问前先搜索,按https://bbs.vpser.net/thread-2555-1-1.html 要求反馈问题!

TOP