打印

ssl安装失败,阿里云的,ubuntu16

ssl安装失败,阿里云的,ubuntu16

It will be processed automatically./bin/certbot [found]index-url=http://mirrors.aliyun.com/pypi/simple/pip.conf exist.Starting create SSL Certificate use Let's Encrypt...Bootstrapping dependencies for Debian-based OSes... (you can skip this with --no-bootstrap)Hit:1 http://mirrors.cloud.aliyuncs.com/ubuntu xenial InReleaseHit:2 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-updates InReleaseHit:3 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-security InRelease               Reading package lists... Done                                                          Reading package lists... DoneBuilding dependency tree       Reading state information... Donegcc is already the newest version (4:5.3.1-1ubuntu1).libffi-dev is already the newest version (3.2.1-4).augeas-lenses is already the newest version (1.4.0-0ubuntu1.1).ca-certificates is already the newest version (20170717~16.04.1).libaugeas0 is already the newest version (1.4.0-0ubuntu1.1).libssl-dev is already the newest version (1.0.2g-1ubuntu4.10).openssl is already the newest version (1.0.2g-1ubuntu4.10).python-virtualenv is already the newest version (15.0.1+ds-3ubuntu1).virtualenv is already the newest version (15.0.1+ds-3ubuntu1).python-dev is already the newest version (2.7.12-1~16.04).python is already the newest version (2.7.12-1~16.04).0 upgraded, 0 newly installed, 0 to remove and 44 not upgraded.Creating virtual environment...Traceback (most recent call last):  File "/usr/lib/python3/dist-packages/virtualenv.py", line 2363, in <module>    main()  File "/usr/lib/python3/dist-packages/virtualenv.py", line 719, in main    symlink=options.symlink)  File "/usr/lib/python3/dist-packages/virtualenv.py", line 988, in create_environment    download=download,  File "/usr/lib/python3/dist-packages/virtualenv.py", line 918, in install_wheel    call_subprocess(cmd, show_stdout=False, extra_env=env, stdin=SCRIPT)  File "/usr/lib/python3/dist-packages/virtualenv.py", line 812, in call_subprocess    % (cmd_desc, proc.returncode))OSError: Command /opt/eff.org/certbot/venv/bin/python2.7 - setuptools pkg_resources pip wheel failed with error code 2Let's Encrypt SSL Certificate create failed!

TOP

自行论坛你搜索错误信息:setuptools pkg_resources pip wheel failed with error code 2
或升级到1.5

TOP