打印

求助 https 301的问题

求助 https 301的问题

军哥求助改下301重定向 ,弄了很久都没成功,看晕了虚拟主机已经开了https, 我需要将 带www和不带www的http   和 不带www的https 全部重定向到 带www的https(https://www.ujitang.com)

这是默认生成的规则,麻烦帮忙改下,谢谢
复制内容到剪贴板
代码:
server
    {
        listen 80;
        #listen [::]:80;
        server_name www.ujitang.com ujitang.com;
        index index.html index.htm index.php default.html default.htm default.php;
        root  /home/wwwroot/www.ujitang.com;

        include wordpress.conf;
        #error_page   404   /404.html;

        # Deny access to PHP files in specific directory
        #location ~ /(wp-content|uploads|wp-includes|images)/.*\.php$ { deny all; }

        include enable-php.conf;

        location ~ .*\.(gif|jpg|jpeg|png|bmp|swf)$
        {
            expires      30d;
        }

        location ~ .*\.(js|css)?$
        {
            expires      12h;
        }

        location ~ /.well-known {
            allow all;
        }

        location ~ /\.
        {
            deny all;
        }

        access_log  /home/wwwlogs/www.ujitang.com.log;
    }

server
    {
        listen 443 ssl http2;
        #listen [::]:443 ssl http2;
        server_name www.ujitang.com ujitang.com;
        index index.html index.htm index.php default.html default.htm default.php;
        root  /home/wwwroot/www.ujitang.com;
        ssl on;
        ssl_certificate /usr/local/nginx/conf/ssl/ujitang.pem;
        ssl_certificate_key /usr/local/nginx/conf/ssl/ujitang.key;
        ssl_session_timeout 5m;
        ssl_protocols TLSv1 TLSv1.1 TLSv1.2;
        ssl_prefer_server_ciphers on;
        ssl_ciphers "EECDH+CHACHA20:EECDH+CHACHA20-draft:EECDH+AES128:RSA+AES128:EECDH+AES256:RSA+AES256:EECDH+3DES:RSA+3DES:!MD5";
        ssl_session_cache builtin:1000 shared:SSL:10m;
        # openssl dhparam -out /usr/local/nginx/conf/ssl/dhparam.pem 2048
        ssl_dhparam /usr/local/nginx/conf/ssl/dhparam.pem;

        include wordpress.conf;
        #error_page   404   /404.html;

        # Deny access to PHP files in specific directory
        #location ~ /(wp-content|uploads|wp-includes|images)/.*\.php$ { deny all; }

        include enable-php.conf;

        location ~ .*\.(gif|jpg|jpeg|png|bmp|swf)$
        {
            expires      30d;
        }

        location ~ .*\.(js|css)?$
        {
            expires      12h;
        }

        location ~ /.well-known {
            allow all;
        }

        location ~ /\.
        {
            deny all;
        }

        access_log  /home/wwwlogs/www.ujitang.com.log;
    }

TOP

论坛内搜索 https 301 以前就说过

LNMP付费问题排查/LNMP技术支持/Paypal信用卡代付/代购VPS,域名,软件等 QQ 503228080 旺旺 lzhenbao
军哥淘宝店铺
QQ/旺旺仅提供代购及付费代维/问题解决等服务,其他不回复!LNMP相关问题请在本论坛发帖,提问前先搜索,按https://bbs.vpser.net/thread-2555-1-1.html 要求反馈问题!

TOP

已经解决,谢谢

之前一直不成功是我把虚拟主机配置文件备份了一个在同目录下,虽然改了名字还是被读取到了,导致定项一直没反应,删掉就好了

TOP