打印

多PHP版本安装5.2.17遇到问题

多PHP版本安装5.2.17遇到问题

case "${PHPSelect}" in
    1)
        echo "You will install ${PHP_Info[0]}"
        MPHP_Path='/usr/local/php5.2'
        if [ "${DB_Name}" == "None" ];then
            Echo_Red "MySQL or MariaDB not found,can't install PHP 5.2!"
            exit 1
        fi
        ;;

安装脚本需要检测MYSQL,我的MYSQL在另外一台机器上,所以检测不到安装不了,如果想安装php5.2的话怎么办?

TOP

if前面少了一行 Check_DB,加上就可以了

LNMP付费问题排查/LNMP技术支持/Paypal信用卡代付/代购VPS,域名,软件等 QQ 503228080 旺旺 lzhenbao
军哥淘宝店铺
QQ/旺旺仅提供代购及付费代维/问题解决等服务,其他不回复!LNMP相关问题请在本论坛发帖,提问前先搜索,按https://bbs.vpser.net/thread-2555-1-1.html 要求反馈问题!

TOP

回复 2# 的帖子

不行啊军哥,我数据库没在同一台机器上,安装LNMP的时候选的不安装数据库,现在检测不到,能不能去掉检测数据库的代码?现在是生产环境,我不敢乱试

TOP

回复 3# 的帖子

你要用脚本安装就必须机器上能正常检查到mysql,要不然没法安装,只能自己去改include/multiplephp.sh 中的判断和php 5.2的参数后再去试,去掉里面mysql的参数应该也就不支持连接mysql了

LNMP付费问题排查/LNMP技术支持/Paypal信用卡代付/代购VPS,域名,软件等 QQ 503228080 旺旺 lzhenbao
军哥淘宝店铺
QQ/旺旺仅提供代购及付费代维/问题解决等服务,其他不回复!LNMP相关问题请在本论坛发帖,提问前先搜索,按https://bbs.vpser.net/thread-2555-1-1.html 要求反馈问题!

TOP