打印

128m内存openvz编译安装lnmp1.5中mysql 5.5失败

128m内存openvz编译安装lnmp1.5中mysql 5.5失败

军哥你好,我的机器是ramnode的openvz,内存128m,swap 64m,最近想尝试编译安装lnmp1.5,选择的mysql版本是5.5,但每次都是mysql编译失败,日志的6207,6280,6353行出现:collect2: error: ld terminated with signal 9 [Killed],除mysql以外安装完成后lnmp命令也不存在。
请问这是因为内存过小编译被kill了么?
这个问题有办法解决么?或者换老版本的mysql?
谢谢

附上log:
附件: 您所在的用户组无法下载或查看附件

TOP

128MB内存太小mysql 5.5有可能安装不上,如果有vswap的话可能会安装上
可以安装mysql 5.1试试
安装失败是没有lnmp命令的

LNMP付费问题排查/LNMP技术支持/Paypal信用卡代付/代购VPS,域名,软件等 QQ 503228080 旺旺 lzhenbao
军哥淘宝店铺
QQ/旺旺仅提供代购及付费代维/问题解决等服务,其他不回复!LNMP相关问题请在本论坛发帖,提问前先搜索,按https://bbs.vpser.net/thread-2555-1-1.html 要求反馈问题!

TOP

回复 2# 的帖子

谢谢军哥,mysql5.1可以装上,但是5.1在我这用着有点小问题,请问如果卸载掉编译安装的mysql直接安装源里的mysql,lnmp命令还能够正常使用么?怎么单独卸载lnmp中的mysql呢?
谢谢

TOP

回复 3# 的帖子

可以,lnmp命令需要根据实际mysql管理脚本的名字进行调整

LNMP付费问题排查/LNMP技术支持/Paypal信用卡代付/代购VPS,域名,软件等 QQ 503228080 旺旺 lzhenbao
军哥淘宝店铺
QQ/旺旺仅提供代购及付费代维/问题解决等服务,其他不回复!LNMP相关问题请在本论坛发帖,提问前先搜索,按https://bbs.vpser.net/thread-2555-1-1.html 要求反馈问题!

TOP

回复 4# 的帖子

好的,谢谢军哥,删掉了编译的mysql5.1换了源里的5.5,改了下lnmp,用着好像没啥问题了

TOP