打印

关于阿里云centos7.4使用lnmp1.5将php升级至7.3.0

关于阿里云centos7.4使用lnmp1.5将php升级至7.3.0

系统:阿里云centos7.4
升级php版本为7.3.0时会报错
复制内容到剪贴板
代码:
configure: error: system libzip must be upgraded to version >=**0.11
编译安装libzip >= 1.5.0的版本需要 版本>=3.0.2的cmake
当我安装好1.5.1的libzip后,用./upgrade.sh时,脚本会判定libzip未安装,然后用yum重新安装一个libzip...我的解决方法是直接在include/upgrade_php.sh搜索libzip然后删除libzip-devel
当我完成上述操作再使用./upgrade.sh时会报错
复制内容到剪贴板
代码:
configure: error: off_t undefined; check your library configuration
解决方法是输入以下命令
复制内容到剪贴板
代码:
echo '/usr/local/lib64
/usr/local/lib
/usr/lib
/usr/lib64'>>/etc/ld.so.conf&&ldconfig -v
最终成功安装php7.3.0

TOP

As of PHP 7.3.0, building against the bundled libzip is discouraged, but still possible by adding --without-libzip to the configuration.

LNMP付费问题排查/LNMP技术支持/Paypal信用卡代付/代购VPS,域名,软件等 QQ 503228080 旺旺 lzhenbao
军哥淘宝店铺
QQ/旺旺仅提供代购及付费代维/问题解决等服务,其他不回复!LNMP相关问题请在本论坛发帖,提问前先搜索,按https://bbs.vpser.net/thread-2555-1-1.html 要求反馈问题!

TOP

我都没有这个提示,直接升级到php7.3.0成功了!可能是因为我的CentOS已经update到7.6的缘故吧!

TOP

只到7.2.6 反正1.6也快来了

TOP