打印

LNMAP php5.5升级到php7.0.27失败

LNMAP php5.5升级到php7.0.27失败

Current PHP Version:5.5.38
You can get version number from http://www.php.net/
Please enter a PHP Version you want:
Press any key to start...or Press Ctrl+c to cancel

Notice: php-7.0.27.tar.bz2 not found!!!download now...
--2019-01-08 15:29:48--  http://cn2.php.net/distributions/php-7.0.27.tar.bz2
Resolving cn2.php.net... 36.51.255.144
Connecting to cn2.php.net|36.51.255.144|:80... connected.
HTTP request sent, awaiting response... 206 Partial Content
Length: 14154690 (13M), 6007750 (5.7M) remaining [application/octet-stream]
Saving to: “php-7.0.27.tar.bz2”


57% [++++++++++++++++++++++                 ] 8,146,940   --.-K/s              
57% [++++++++++++++++++++++                 ] 8,164,119   49.5K/s              
57% [++++++++++++++++++++++                 ] 8,180,179   48.1K/s              
57% [++++++++++++++++++++++                 ] 8,196

2019-01-08 15:36:43 (17.0 KB/s) - “php-7.0.27.tar.bz2” saved [14154690/14154690]

Download php-7.0.27.tar.bz2 successfully!
+-------------------------------------------+
|    Manager for LNMP, Written by Licess    |
+-------------------------------------------+
|              https://lnmp.org             |
+-------------------------------------------+
Stoping LAMP...
stop apache...  done
Shutting down MySQL.... SUCCESS!
[+] Installing 7.0.27
Loaded plugins: fastestmirror
Setting up Install Process
Determining fastest mirrors
Package libicu-devel-4.2.1-14.el6.x86_64 already installed and latest version
Nothing to do
Uncompress php-7.0.27.tar.bz2...

bzip2: Data integrity error when decompressing.

Input file = (stdin), output file = (stdout)

It is possible that the compressed file(s) have become corrupted.
You can use the -tvv option to test integrity of such files.

You can use the `bzip2recover' program to attempt to recover
data from undamaged sections of corrupted files.

tar: Unexpected EOF in archive
tar: Unexpected EOF in archive
tar: Error is not recoverable: exiting now
cd php-7.0.27...
include/upgrade_php.sh: line 528: ./configure: No such file or directory
make: *** No targets specified and no makefile found.  Stop.
make: *** No rule to make target `install'.  Stop.
Copy new php configure file...
cp: cannot stat `php.ini-production': No such file or directory
Modify php.ini......
sed: can't read /usr/local/php/etc/php.ini: No such file or directory
sed: can't read /usr/local/php/etc/php.ini: No such file or directory
sed: can't read /usr/local/php/etc/php.ini: No such file or directory
sed: can't read /usr/local/php/etc/php.ini: No such file or directory
sed: can't read /usr/local/php/etc/php.ini: No such file or directory
sed: can't read /usr/local/php/etc/php.ini: No such file or directory
sed: can't read /usr/local/php/etc/php.ini: No such file or directory
include/upgrade_php.sh: line 104: pear: command not found
include/upgrade_php.sh: line 105: pecl: command not found
include/php.sh: line 29: php: command not found
curl: (23) Failed writing body (0 != 16133)
Install ZendGuardLoader for PHP 7...
unavailable now.
Write ZendGuardLoader to php.ini...
+-------------------------------------------+
|    Manager for LNMP, Written by Licess    |
+-------------------------------------------+
|              https://lnmp.org             |
+-------------------------------------------+
Starting LAMP...
start apache...  done
Starting MySQL... SUCCESS!
======== upgrade php failed ======
upgrade php log: /root/upgrade_a_php.log
You upload upgrade_a_php.log to LNMP Forum for help.


复制的错误信息~求大神解答下!!!用的thinkphp3.2搭建的网站,现在一刷新就下载index.php文件~该怎么办啊~
全部错误日志:
附件: 您所在的用户组无法下载或查看附件

TOP

用的阿里云

CentOS  6.8 64位安装的lnmpa

TOP

php源码包是不完整的,删除lnmp安装包src目录下的 php-7.0.27.tar.bz2 ,然后重新安装
php升级失败了,你访问php文件会提示502错误,出现php下载是虚拟主机中的php解析部分有可能改过导致的

LNMP付费问题排查/LNMP技术支持/Paypal信用卡代付/代购VPS,域名,软件等 QQ 503228080 旺旺 lzhenbao
军哥淘宝店铺
QQ/旺旺仅提供代购及付费代维/问题解决等服务,其他不回复!LNMP相关问题请在本论坛发帖,提问前先搜索,按https://bbs.vpser.net/thread-2555-1-1.html 要求反馈问题!

TOP