打印

安装ownCloud的的问题

安装ownCloud的的问题

军哥,我安装好ownCloud之后,提示以下信息,需要改进吗?
  • PHP 似乎没有设置好查询的系统环境变量。 用 getenv(\"PATH\") 测试只返回一个空值。
    请检查PHP配置说明和服务器的 PHP 配置的 安装文档 ↗,使用 PHP-FPM 时尤其如此。
  • PHP模块'文件信息'丢失. 我们强烈建议启用此模块以便mime类型检测取得最佳结果.
  • Some files have not passed the integrity check. Further information on how to resolve this issue can be found in our documentation. (List of invalid files… / Rescan…)
  • 此服务器上没有可用的因特网连接. 这意味着某些特性将无法工作,例如挂载外部存储器, 提醒更新或安装第三方应用等. 从远程访问文件和发送提醒电子邮件也可能无法工作. 如果你想要ownCloud的所有特性, 我们建议启用此服务器的因特网连接.
  • /dev/urandom is not readable by PHP which is highly discouraged for security reasons. Further information can be found in our documentation.
  • cURL使用了过时 NSS 版本 (NSS/3.19.1 Basic ECC)。请更新你的操作系统或功能比如 通过应用程序商店或联合云共享安装和更新应用程序 将无法可靠地工作。

TOP

getenv问题:在php-fpm.conf 中加上 env[PATH] = /usr/local/bin:/usr/bin:/bin:/usr/local/php/bin重启一下php-fpm就可以了

PHP模块'文件信息'丢失:自己参考:https://www.vpser.net/manage/lnmp-php-install-ext.html 安装上phpinfo模块

Some files have not passed the integrity check. :估计可能是与禁用函数有关,按置顶帖去掉scandir函数试试


此服务器上没有可用的因特网连接. :不清楚原因,可能就是字面意思没连外网


/dev/urandom is not readable by PHP which is highly discouraged for security reasons.问题 这个可以参照这个 https://lnmp.org/faq/lnmp-vhost-add-howto.html#user.ini 修改


cURL使用了过时 NSS 版本 (NSS/3.19.1 Basic ECC) 问题:说明你系统是centos 6或更老的版本,建议更新curl,不更新应该也不影响正常使用


owncloud一般要开启pathinfo
1.2或1.3的话对应虚拟主机配置文件里的 include enable-php.conf; 要改成 include enable-php-pathinfo.conf; 并重启或reload nginx

LNMP付费问题排查/LNMP技术支持/Paypal信用卡代付/代购VPS,域名,软件等 QQ 503228080 旺旺 lzhenbao
军哥淘宝店铺
QQ/旺旺仅提供代购及付费代维/问题解决等服务,其他不回复!LNMP相关问题请在本论坛发帖,提问前先搜索,按https://bbs.vpser.net/thread-2555-1-1.html 要求反馈问题!

TOP

军哥,我用的是LNMPA 1.4测试版,貌似有些配置文件跟之前的不一样啊?军哥,LNMPA 1.4测试版的phpinfo我确实找不到在哪儿可以开,求指点

[ 本帖最后由 孤鸿掠影 于 2017-4-6 17:12 编辑 ]

TOP

autoconf 提示版本2.59或更高的版本

我在编译php7 扩展 imap时,/usr/local/php/bin/phpize 命令提示: FATAL ERROR: Autoconf version 2.59 or higher is required for this script,但是,我查了版本是2.69的,怎么会出现这个问题

owncloud 10建议用php7,升级编译了php7

TOP

回复 4# 的帖子

搜一下看看是否存在多个auotconf,可能系统使用了低版本的autoconf

LNMP付费问题排查/LNMP技术支持/Paypal信用卡代付/代购VPS,域名,软件等 QQ 503228080 旺旺 lzhenbao
军哥淘宝店铺
QQ/旺旺仅提供代购及付费代维/问题解决等服务,其他不回复!LNMP相关问题请在本论坛发帖,提问前先搜索,按https://bbs.vpser.net/thread-2555-1-1.html 要求反馈问题!

TOP

确实是有个2.13的版本,怎么去掉他呢。谢谢军哥

============================ N/S matched: autoconf =============================
autoconf-archive.noarch : The Autoconf Macro Archive
php-horde-Horde-Mail-Autoconfig.noarch : Horde Mail Autoconfiguration
autoconf.noarch : A GNU tool for automatically configuring source code
autoconf213.noarch : A GNU tool for automatically configuring source code
perl-HTTP-ProxyAutoConfig.noarch : Use a .pac or wpad.dat file to get proxy

TOP

回复 6# 的帖子

如果确定安装时调用的这个包的话,看包名称应该是centos,可以rpm -e autoconf213 --nodeps 进行删除

LNMP付费问题排查/LNMP技术支持/Paypal信用卡代付/代购VPS,域名,软件等 QQ 503228080 旺旺 lzhenbao
军哥淘宝店铺
QQ/旺旺仅提供代购及付费代维/问题解决等服务,其他不回复!LNMP相关问题请在本论坛发帖,提问前先搜索,按https://bbs.vpser.net/thread-2555-1-1.html 要求反馈问题!

TOP

试过了,
error: package autoconf213 is not installed,

怎么回事? 还是要哪里手动删除

TOP

回复 8# 的帖子

按提示没有安装过autoconf213

LNMP付费问题排查/LNMP技术支持/Paypal信用卡代付/代购VPS,域名,软件等 QQ 503228080 旺旺 lzhenbao
军哥淘宝店铺
QQ/旺旺仅提供代购及付费代维/问题解决等服务,其他不回复!LNMP相关问题请在本论坛发帖,提问前先搜索,按https://bbs.vpser.net/thread-2555-1-1.html 要求反馈问题!

TOP