打印

vultr debian7 php没有安装成功,求解

vultr debian7 php没有安装成功,求解

其他都安装成功了  提示php-fpm 没有这个文件  重新安装php5.2也没有成功
附件: 您所在的用户组无法下载或查看附件

TOP

引用:
The following packages have unmet dependencies: libcurl4-gnutls-dev : Depends: libgnutls-dev but it is not going to be installed
                       Depends: libldap2-dev but it is not going to be installed
                       Depends: librtmp-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:


The following packages have unmet dependencies:
libcurl4-openssl-dev : Depends: libldap2-dev but it is not going to be installed
                        Depends: librtmp-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
libcurl的包没安装上导致的
你这个应该是vultr的debian 7,先执行一下apt-get install libcurl4-openssl-dev
引用:
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Picking 'curl' as source package instead of 'libcurl4-openssl-dev'
The following packages have unmet dependencies:
libgnutls-dev : Depends: libp11-kit-dev (>= 0.4) but it is not going to be installed
libldap2-dev : Depends: libldap-2.4-2 (= 2.4.31-2+deb7u1) but 2.4.31+really2.4.40+dfsg-1+deb8u1~bpo70+1 is to be installed
E: Build-dependencies for libcurl4-openssl-dev could not be satisfied.
执行 apt-get install libp11-kit-dev 报如下错误:
引用:
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libp11-kit-dev : Depends: libp11-kit0 (= 0.12-3) but 0.20.7-1~bpo70+1 is to be installed
E: Unable to correct problems, you have held broken packages.
这个是由于libp11-kit0这个版本不高造成的,执行一下:apt-get install libp11-kit0=0.12-3 指定上版本(具体版本按上面最后结尾提示里=后面的版本)应该就可以了,再重新安装或升级一下php

最简单的方法就是换debian 8

TOP

回复 2# 的帖子

谢军哥指点。  希望你能坚持下来。 继续做。  加油

TOP

我测试的是vultr的debian 7要先安装5.2.17,因为文件夹里面就只有它。安装一切顺利。然后再用升级脚本可以自由升级PHP,我升级到5.6.19也一样正常了

TOP

回复 4# 的帖子

我在loc看到你啦。。

TOP

安装日志在哪里呢,我是centos 6.5 64位

TOP

回复 6# 的帖子

自己可置顶帖反馈必读或官网说明https://lnmp.org/install.html#installfailed

TOP