VPS侦探论坛

 找回密码
 注册
查看: 2250|回复: 6

lnmp 1.3可以支持升级到1.4么?

[复制链接]
发表于 2016-12-6 15:13:24 | 显示全部楼层 |阅读模式


如题, 因为有看到可以自动安装ssl什么的了,很方便,或者最后从1.3之后可以支持升级哇, 比如上传覆盖就行,这样1.3以后就可以直接使用后面的版本?
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org/
发表于 2016-12-6 15:36:09 | 显示全部楼层


lnmp管理脚本可以拷过去直接用,但是如果是已存在的虚拟主机涉及到Letsencrypt时还是需要提前修改配置文件的,参考:https://www.vpser.net/build/letsencrypt-certbot.html 注意事项第1条

如果还要使用http2的话还需要在lnmp1.4目录下运行./upgrade.sh nginx 升级nginx到1.10.3或更高版本

未添加过的虚拟主机直接用新版的脚本添加就行
用 ./upgrade1.x-1.4.sh 就可以直接自动升级手动操作的话直接将conf 目录下的lnmp 文件cp到/bin/ 下就行,其他模式的话就是lnmpa 或lamp 文件cp过去更名为lnmp
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
 楼主| 发表于 2016-12-7 09:24:04 | 显示全部楼层

我可以理解为.
直接下载1.4的包覆盖或者删除以前的1.3的就可以正常使用么?

比如升级php  mysql包括ftp管理这些?
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org/
发表于 2016-12-7 09:48:39 | 显示全部楼层

回复 3# 的帖子




1.4的包升级nginx、mysql、php都是可以的,如果要用1.4的包安装php模块的话是需要用1.4的包先升级一下php才能直接用
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2016-12-12 11:17:43 | 显示全部楼层

回复 4# 的帖子




也就是说如果不考虑已存在的虚拟主机涉及到Letsencrypt,什么都不用做直接用1.4即可,升级nginx、mysql、php都是可以,想安装php模块必要要先用1.4的包升级一下php才可以继续,对吗?
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2016-12-12 13:16:27 | 显示全部楼层

回复 5# 的帖子




是的
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org/
发表于 2016-12-12 14:34:17 | 显示全部楼层

回复 6# 的帖子


恩,好的 谢谢,已验证,可行!

美国VPS、VPN、域名代购:http://shop63846532.taobao.com/

您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2019-9-18 03:57 , Processed in 0.053752 second(s), 26 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表