打印

求助,军哥你好,nginx反向代理+https 用户无法登陆。

求助,军哥你好,nginx反向代理+https 用户无法登陆。

求助军哥,nginx反向代理+https  搭建wordpress 用户无法登陆。


前端配置-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
server {listen 80;server_name www.tgcoe.com tgcoe.com;return 301 https://www.tgcoe.com$request_uri;}server    {        listen 443 ssl http2;        #listen [::]:443 ssl http2;        server_name www.tgcoe.com tgcoe.com;        #index index.html index.htm index.php default.html default.htm default.php;        #root  /home/wwwroot/www.tgcoe.com;        ssl on;        ssl_certificate /etc/letsencrypt/live/www.tgcoe.com/fullchain.pem;        ssl_certificate_key /etc/letsencrypt/live/www.tgcoe.com/privkey.pem;        ssl_session_timeout 5m;        ssl_protocols TLSv1 TLSv1.1 TLSv1.2;        ssl_prefer_server_ciphers on;        ssl_ciphers "EECDH+CHACHA20:EECDH+CHACHA20-draft:EECDH+AES128:RSA+AES128:EECDH+AES256:RSA+AES256:EECDH+3DES:RSA+3DES:!MD5";        ssl_session_cache builtin:1000 shared:SSL:10m;        # openssl dhparam -out /usr/local/nginx/conf/ssl/dhparam.pem 2048        ssl_dhparam /usr/local/nginx/conf/ssl/dhparam.pem;        #include wordpress.conf;        #error_page   404   /404.html;        # Deny access to PHP files in specific directory        #location ~ /(wp-content|uploads|wp-includes|images)/.*\.php$ { deny all; }        #include enable-php.conf;        location /         {        proxy_set_header Host $host;        proxy_set_header X-Real-Ip $remote_addr;        proxy_set_header X-Forwarded-For $remote_addr;        proxy_pass http://zx.aoirs.com:7777/;          }        access_log  /home/wwwlogs/www.tgcoe.com.log;    }




后端配置------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
server
    {
        listen 7777;
        #listen [::]:7777;
        server_name www.tgcoe.com tgcoe.com;
        index index.html index.htm index.php default.html default.htm default.php;
        root  /home/wwwroot/www.tgcoe.com;

        #error_page   404   /404.html;

        # Deny access to PHP files in specific directory
        #location ~ /(wp-content|uploads|wp-includes|images)/.*\.php$ { deny all; }

        include proxy-pass-php.conf;

        location ~ .*\.(gif|jpg|jpeg|png|bmp|swf)$
        {
            expires      30d;
        }

        location ~ .*\.(js|css)?$
        {
            expires      12h;
        }

        location ~ /.well-known {
            allow all;
        }

        location ~ /\.
        {
            deny all;
        }

        access_log  /home/wwwlogs/www.tgcoe.com.log;
    }

TOP

wordpress登陆好像是读取数据库里的链接吧

TOP

网站数据库密码都是后端的,是不是session的问题啊,对这个一头雾水

TOP

回复 2# 的帖子

网站数据库密码都是后端的,是不是session的问题啊,对这个一头雾水

TOP

回复 4# 的帖子

不清楚

TOP