打印

lnmp1.4 安装多php出错

lnmp1.4 安装多php出错

军哥 您好
腾讯云服务器 centos 6.8系统 ,多个php安装不上。
详细的错误麻烦请您看下日志,谢谢了。
附件: 您所在的用户组无法下载或查看附件

TOP

引用:
Thank you for using PHP.

/bin/sh /root/lnmp1.4/src/php-5.3.29/libtool --silent --preserve-dup-deps --mode=compile gcc -Iext/date/lib -Iext/date/ -I/root/lnmp1.4/src/php-5.3.29/ext/date/ -DPHP_ATOM_INC -I/root/lnmp1.4/src/php-5.3.29/include -I/root/lnmp1.4/src/php-5.3.29/main -I/root/lnmp1.4/src/php-5.3.29 -I/root/lnmp1.4/src/php-5.3.29/ext/date/lib -I/root/lnmp1.4/src/php-5.3.29/ext/ereg/regex -I/usr/include/libxml2 -I/usr/local/curl/include -I/usr/local/freetype/include -I/usr/local/freetype/include/freetype2 -I/root/lnmp1.4/src/php-5.3.29/ext/mbstring/oniguruma -I/root/lnmp1.4/src/php-5.3.29/ext/mbstring/libmbfl -I/root/lnmp1.4/src/php-5.3.29/ext/mbstring/libmbfl/mbfl -I/usr/local/include -I/root/lnmp1.4/src/php-5.3.29/ext/sqlite3/libsqlite -I/root/lnmp1.4/src/php-5.3.29/TSRM -I/root/lnmp1.4/src/php-5.3.29/Zend    -I/usr/local/include -g -O2 -fvisibility=hidden  -c /root/lnmp1.4/src/php-5.3.29/ext/date/php_date.c -o ext/date/php_date.lo
env: gcc: Permission denied
make: *** [ext/date/php_date.lo] Error 1
/bin/sh /root/lnmp1.4/src/php-5.3.29/libtool --silent --preserve-dup-deps --mode=compile gcc -Iext/date/lib -Iext/date/ -I/root/lnmp1.4/src/php-5.3.29/ext/date/ -DPHP_ATOM_INC -I/root/lnmp1.4/src/php-5.3.29/include -I/root/lnmp1.4/src/php-5.3.29/main -I/root/lnmp1.4/src/php-5.3.29 -I/root/lnmp1.4/src/php-5.3.29/ext/date/lib -I/root/lnmp1.4/src/php-5.3.29/ext/ereg/regex -I/usr/include/libxml2 -I/usr/local/curl/include -I/usr/local/freetype/include -I/usr/local/freetype/include/freetype2 -I/root/lnmp1.4/src/php-5.3.29/ext/mbstring/oniguruma -I/root/lnmp1.4/src/php-5.3.29/ext/mbstring/libmbfl -I/root/lnmp1.4/src/php-5.3.29/ext/mbstring/libmbfl/mbfl -I/usr/local/include -I/root/lnmp1.4/src/php-5.3.29/ext/sqlite3/libsqlite -I/root/lnmp1.4/src/php-5.3.29/TSRM -I/root/lnmp1.4/src/php-5.3.29/Zend    -I/usr/local/include -g -O2 -fvisibility=hidden  -c /root/lnmp1.4/src/php-5.3.29/ext/date/php_date.c -o ext/date/php_date.lo
env: gcc: Permission denied
make: *** [ext/date/php_date.lo] Error 1
有可能是腾讯云上的安全软件或云锁等之类的安全软件造成的

TOP

回复 2# 的帖子

我刚把腾讯的安全组件卸在了 云锁暂停了 还是不行。
附件: 您所在的用户组无法下载或查看附件

TOP

回复 3# 的帖子

这个不大清楚,依然是前面的错误提示

TOP

回复 4# 的帖子

好的,谢谢军哥。


.

TOP