打印

一键安装lnmp失败,求助

一键安装lnmp失败,求助

centos 7.3 64位

wget -c http://soft.vpser.net/lnmp/lnmp1.4.tar.gz && tar zxf lnmp1.4.tar.gz && cd lnmp1.4 && ./install.shlnmp

lnmp.cof 加入Nginx_Modules_Options='--with-openssl=/root/openssl-1.0.2l'

报错
Nginx: OK
MySQL: OK
Error: PHP install failed.
Sorry, Failed to install LNMP!
Please visit https://bbs.vpser.net/forum-25-1.html feedback errors and logs.
You can download /root/lnmp-install.log from your server,and upload lnmp-install.log to LNMP Forum.

[ 本帖最后由 371663062 于 2017-9-5 14:09 编辑 ]
附件: 您所在的用户组无法下载或查看附件

TOP

1.4本来就默认自带了openssl 1.0.2
引用:
/root/lnmp1.4/src/php-7.1.7/ext/iconv/iconv.c:1002: undefined reference to `libiconv_open'
/root/lnmp1.4/src/php-7.1.7/ext/iconv/iconv.c:1030: undefined reference to `libiconv'
/root/lnmp1.4/src/php-7.1.7/ext/iconv/iconv.c:1144: undefined reference to `libiconv_close'
ext/xmlrpc/libxmlrpc/.libs/encodings.o: In function `convert':
/root/lnmp1.4/src/php-7.1.7/ext/xmlrpc/libxmlrpc/encodings.c:74: undefined reference to `libiconv_open'
/root/lnmp1.4/src/php-7.1.7/ext/xmlrpc/libxmlrpc/encodings.c:82: undefined reference to `libiconv'
/root/lnmp1.4/src/php-7.1.7/ext/xmlrpc/libxmlrpc/encodings.c:102: undefined reference to `libiconv_close'
/root/lnmp1.4/src/php-7.1.7/ext/xmlrpc/libxmlrpc/encodings.c:102: undefined reference to `libiconv_close'
这个只能换其他php版本或者debian版本

TOP