打印

PHP安装不成功 libxml2-dev : Depends: libxml2 (= 2.9.1+dfsg1-5+deb8u4) but 2.9.1+dfsg1-5+deb8u5 is to be installed

PHP安装不成功 libxml2-dev : Depends: libxml2 (= 2.9.1+dfsg1-5+deb8u4) but 2.9.1+dfsg1-5+deb8u5 is to be installed

系统是阿里云Debian8.9  64位   头一次遇见这种情况,谢谢了
附件: 您所在的用户组无法下载或查看附件

TOP

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libxml2-dev : Depends: libxml2 (= 2.9.1+dfsg1-5+deb8u4) but 2.9.1+dfsg1-5+deb8u5 is to be installed
E: Unable to correct problems, you have held broken packages.

你系统上的这个libxml2版本不对导致 libxml2-dev 没安装上
可以dpkg --force-all -P libxml2 强制卸载
然后apt-get install libxml2 libxml2-dev 后再看看libxml2能否正常安装上

TOP

回复 2# 的帖子

执行dpkg -r libxml2命令后出现这个,正常吗?
dpkg: dependency problems prevent removal of libxml2:amd64:
libxml-libxml-perl depends on libxml2 (>= 2.7.4).
shared-mime-info depends on libxml2 (>= 2.7.4).
liblwres90 depends on libxml2 (>= 2.6.27).
libcroco3:amd64 depends on libxml2 (>= 2.7.4).
libisc95 depends on libxml2 (>= 2.7.4).
libbind9-90 depends on libxml2 (>= 2.6.27).
libisccfg90 depends on libxml2 (>= 2.6.27).
dnsutils depends on libxml2 (>= 2.6.27).
libarchive13:amd64 depends on libxml2 (>= 2.7.4).
gettext depends on libxml2 (>= 2.7.4).
libisccc90 depends on libxml2 (>= 2.6.27).
libdns100 depends on libxml2 (>= 2.6.27).
bind9-host depends on libxml2 (>= 2.6.27).

dpkg: error processing package libxml2:amd64 (--remove):
dependency problems - not removing
Errors were encountered while processing:
libxml2:amd64

TOP

回复 2# 的帖子

再执行apt-get install libxml2 libxml2-dev后还是出现这个提示

Reading package lists... Done
Building dependency tree      
Reading state information... Done
libxml2 is already the newest version.
libxml2 set to manually installed.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libxml2-dev : Depends: libxml2 (= 2.9.1+dfsg1-5+deb8u4) but 2.9.1+dfsg1-5+deb8u5 is to be installed
E: Unable to correct problems, you have held broken packages.

TOP

回复 4# 的帖子

可以尝试 dpkg --force-all -P libxml2 强制卸载后再按2楼方式安装libxml2

TOP

回复 5# 的帖子

OK,解决了,非常感谢

TOP