打印

lnmp1.4 安装php失败

lnmp1.4 安装php失败

平台:Google Cloud Platform,系统信息:Debian 8.9 64位 Debian GNU/Linux 8 (jessie) Linux gcp 4.13.0-041300-generic #201709031731 SMP Sun Sep 3 21:33:09 UTC 2017 x86_64 GNU/Linux
错误:
Add Startup and Starting LNMP...
Add nginx service at system startup...
Starting nginx...  done
Add mariadb service at system startup...
Starting mariadb (via systemctl): mariadb.service.
Add php-fpm service at system startup...
update-rc.d: error: initscript does not exist: /etc/init.d/php-fpm
include/end.sh: line 54: /etc/init.d/php-fpm: No such file or directory

[ 本帖最后由 michaelchoi 于 2017-9-24 19:24 编辑 ]
附件: 您所在的用户组无法下载或查看附件

TOP

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libpq-dev : Depends: libssl-dev but it is not going to be installed
             Depends: krb5-multidev but it is not going to be installed
             Depends: comerr-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

The following packages have unmet dependencies:
libc-client2007e-dev : Depends: comerr-dev but it is not going to be installed
                        Depends: krb5-multidev but it is not going to be installed
                        Depends: libssl-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

你系统上软件依赖有问题导致的,可以参考:https://bbs.vpser.net/thread-13449-1-1.html 的思路尝试解决
也可以换其他版本系统或发行版
也可以联系QQ/旺旺付费解决

TOP