打印

lnmp1.4安装咨询

lnmp1.4安装咨询

lnmp1.4安装咨询,1核1G的情况下,安装PHP7的话,要选择哪个MYSQL版本搭配好呢?mysql-5.5.56与mysql-5.7.18相差无几是吧?另外,php-7.1.7的话是一个安全性版本吧!?但就在今天 PHP 7.1.11发布 了,是一个错误修复版本哪个版本好?PHP.NET鼓励所有PHP 7.1用户升级到此版本。
如果要升级到7.1.11要如何升级?选择了PHP7后,Jemalloc或TCmalloc是否就不需要安装了?
nginx的就只有一个nginx-1.12.1版本?

TOP

php7选mysql 5.5 5.7都行,但你配置这么低,mysql 5.7肯定装不上
你可以去官网上看每个版本的发布日志上都会提示你升级
官网上都提供了各种程序的升级脚本和教程,可以去 https://lnmp.org 去看一下
没安装前也可以自己修改include/version.sh 中要改的版本号,自己下载你指定版本的程序源码至src目录下,自行改版本因为没测试兼容性不一定能保证

TOP

引用:
原帖由 licess 于 2017-10-28 09:38 发表 .
如果我修改安装脚本后安装新的PHP7的话:只需要下载相对应版本的tar.bz2就可以了吗,其他的类似Zend之类的就不用修改了吗?

另外,安全版本修复版本有什么区别呢?

TOP

回复 3# 的帖子

是,php7 没zend那几个

不清楚你说的安全版本与修复版本是什么,具体php版本间的区别需要自行看php官网上每次的更新日志

TOP

引用:
原帖由 licess 于 2017-10-29 19:37 发表
是,php7 没zend那几个

不清楚你说的安全版本与修复版本是什么,具体php版本间的区别需要自行看php官网上每次的更新日志
下面是从PHP官方上的内容介绍,不知安全版本与修复版本有何区别?php7.1.11 This is a bugfix release PHP 7.1.7. This is a security release
复制内容到剪贴板
代码:
PHP 7.1.11 Released
27 Oct 2017The PHP development team announces the immediate availability of PHP 7.1.11. This is a bugfix release, with several bug fixes included. All PHP 7.1 users are encouraged to upgrade to this version.
复制内容到剪贴板
代码:
PHP 7.1.7 Released

06 Jul 2017
The PHP development team announces the immediate availability of PHP 7.1.7. This is a security release with several bug fixes included. All PHP 7.1 users are encouraged to upgrade to this version.
[ 本帖最后由 kkfgef 于 2017-10-30 10:49 编辑 ]

TOP