打印

lnmp1.4 双php版本xcache 问题

lnmp1.4 双php版本xcache 问题

lnmp1.4  安装了php7.0.21 和 PHP5.3.29  ,想给php5.3.29加个xcache
按照  ./addons.sh install eaccelerator 执行,安装显示是成功的,但打开时报错如下图

图中右下图好像识别的是php7.0.21,所以导致路径不对?
PHP -V没有xache信息(PHP -V默认是显示 PHP7 版本的)
然后我在/usr/local/php5.3/lib/php/php.ini 中添加了
复制内容到剪贴板
代码:
extension=/usr/local/php5.3/lib/php/extensions/no-debug-non-zts-20090626/xcache.so

重启时出现警告:
复制内容到剪贴板
代码:
NOTICE: PHP message: PHP Warning:  Module 'XCache' already loaded in Unknown on line 0


求解,军哥帮个忙!!


[ 本帖最后由 lfeven 于 2017-11-6 01:26 编辑 ]
附件: 您所在的用户组无法下载或查看附件

TOP

前面的命令和你说的php.ini目录都不对,安装xcache是 ./addons.sh install xcache
php.ini 目录是 /usr/local/php5.3/etc/php.ini

警告不用管,他这个可能是直接读取php.ini进行判断的
不需要你自己去添加本来就都添加好了,再添加肯定提示已经有了

TOP

回复 2# 的帖子

不好意思军哥,是按照 ./addons.sh install xcache 安装的,但提示是按图片所述 xcache.so 未载入

怀疑是不是双PHP版本导致Xcache识别不了,因为看图片右下角是 php7.0.21,但是安装时我明明选择是PHP5.3.29

尝试了下重新安装 eaccelerator
安装都成功的,但php -v 没有出来

[ 本帖最后由 lfeven 于 2017-11-6 14:38 编辑 ]
附件: 您所在的用户组无法下载或查看附件

TOP

php -v显示的是你默认php版本的信息,肯定没有你php 5.3的信息,要显示非默认版本的php -v 信息,加上完整路径

TOP