打印

lnmp1.2升级1.4后,安装多PHP版本出错

lnmp1.2升级1.4后,安装多PHP版本出错

环境:CentOS 6.5 情况说明:lnmp1.2升级1.4后,安装多PHP版本出错。
log文件,请见附件。
麻烦帮我看看,怎么解决?谢谢。
附件: 您所在的用户组无法下载或查看附件

TOP

--2017-12-01 23:50:22--  https://soft.vpser.net/web/zend/zend-loader-php5.5-linux-i386.tar.gz
Resolving soft.vpser.net... 45.34.93.228, 2600:3c01::f03c:91ff:fe92:1a06
Connecting to soft.vpser.net|45.34.93.228|:443... connected.
HTTP request sent, awaiting response... 416 Requested Range Not Satisfiable

    The file is already fully retrieved; nothing to do.

Write ZendGuardLoader to php.ini...
Creating new php-fpm configure file...
Copy php-fpm init.d file...
cp: cannot stat `/root/lnmp1.4/src/php-5.5.38/sapi/fpm/init.d.php-fpm': No such file or directory
chmod: cannot access `/etc/init.d/php-fpm5.5': No such file or directory
Add php-fpm5.5 service at system startup...
error reading information on service php-fpm5.5: No such file or directory
error reading information on service php-fpm5.5: No such file or directory
+-------------------------------------------+
|    Manager for LNMP, Written by Licess    |
+-------------------------------------------+
|              https://lnmp.org             |
+-------------------------------------------+
Starting LNMP...
Starting nginx... nginx: [warn] conflicting server name "zhuihao.wang" on 0.0.0.0:80, ignored
nginx: [warn] conflicting server name "www.zhuihao.wang" on 0.0.0.0:80, ignored
done
Starting MySQL.. SUCCESS!
Starting php-fpm  done
Failed to install php-5.5.38, you can download /root/install-mphp5.5.log from your server, and upload install-mphp5.5.log to LNMP Forum.

TOP

yum install libc-client-devel psmisc libXpm-devel git-core c-ares-devel libicu-devel libxslt libxslt-devel xz expat-devel
后再试一下

TOP

军哥,输入后报错。
[root@vps ~]# yum libc-client-devel psmisc libXpm-devel git-core c-ares-devel libicu-devel libxslt libxslt-devel xz expat-devel
Loaded plugins: fastestmirror
No such command: libc-client-devel. Please use /usr/bin/yum --help

TOP

回复 4# 的帖子

yum install libc-client-devel psmisc libXpm-devel git-core c-ares-devel libicu-devel libxslt libxslt-devel xz expat-devel

TOP

引用:
原帖由 licess 于 2017-12-3 11:03 发表
yum install libc-client-devel psmisc libXpm-devel git-core c-ares-devel libicu-devel libxslt libxslt-devel xz expat-devel
解决了,谢谢军哥

TOP