打印

获取和续期Let'sEncrypt SSL证书失败

获取和续期Let'sEncrypt SSL证书失败

今天新增加网站发现获取Let'sEncrypt SSL证书失败,错误信息如下:
复制内容到剪贴板
代码:
pip prints the following errors:
=====================================================
Collecting argparse==1.4.0 (from -r /tmp/tmp.9CirkHigAi/letsencrypt-auto-requirements.txt (line 11))
  Downloading https://pypi.doubanio.com/packages/f2/94/3af39d34be01a24a6e65433d19e107099374224905f1e0cc6bbe1fd22a2f/argparse-1.4.0-py2.py3-none-any.whl
Collecting pycparser==2.14 (from -r /tmp/tmp.9CirkHigAi/letsencrypt-auto-requirements.txt (line 17))
  Downloading https://pypi.doubanio.com/packages/6d/31/666614af3db0acf377876d48688c5d334b6e493b96d21aa7d332169bee50/pycparser-2.14.tar.gz (223kB)
Collecting asn1crypto==0.22.0 (from -r /tmp/tmp.9CirkHigAi/letsencrypt-auto-requirements.txt (line 21))
  Downloading https://pypi.doubanio.com/packages/97/ba/7e8117d8efcee589f4d96dd2b2eb1d997f96d27d214cf2b7134ad8acf6ab/asn1crypto-0.22.0-py2.py3-none-any.whl (97kB)
Collecting cffi==1.10.0 (from -r /tmp/tmp.9CirkHigAi/letsencrypt-auto-requirements.txt (line 24))
  Downloading https://pypi.doubanio.com/packages/50/85/d74d06ac09fc2deb3d9bd6d6aca4ca13d82b8118c04494cd0e84fcd81624/cffi-1.10.0-cp27-cp27mu-manylinux1_x86_64.whl (392kB)
Collecting ConfigArgParse==0.12.0 (from -r /tmp/tmp.9CirkHigAi/letsencrypt-auto-requirements.txt (line 61))
  Downloading https://pypi.doubanio.com/packages/17/8d/4a41f11b0971017c7001f118be8003da8f7b96b010c66cd792b76658d1e1/ConfigArgParse-0.12.0.tar.gz (41kB)
Collecting configobj==5.0.6 (from -r /tmp/tmp.9CirkHigAi/letsencrypt-auto-requirements.txt (line 63))
  Downloading https://pypi.doubanio.com/packages/64/61/079eb60459c44929e684fa7d9e2fdca403f67d64dd9dbac27296be2e0fab/configobj-5.0.6.tar.gz
Collecting cryptography==2.0.2 (from -r /tmp/tmp.9CirkHigAi/letsencrypt-auto-requirements.txt (line 65))
  Downloading https://pypi.doubanio.com/packages/b2/c3/713d3a0c964acd704ee2b8521f51706aa8053fc5addbcd43cb03d74819e7/cryptography-2.0.2-cp27-cp27mu-manylinux1_x86_64.whl (2.2MB)
Collecting enum34==1.1.2 (from -r /tmp/tmp.9CirkHigAi/letsencrypt-auto-requirements.txt (line 96))
  Downloading https://pypi.doubanio.com/packages/6f/e9/08fd439384b7e3d613e75a6c8236b8e64d90c47d23413493b38d4229a9a5/enum34-1.1.2.tar.gz (46kB)
Collecting funcsigs==1.0.2 (from -r /tmp/tmp.9CirkHigAi/letsencrypt-auto-requirements.txt (line 99))
  Downloading https://pypi.doubanio.com/packages/69/cb/f5be453359271714c01b9bd06126eaf2e368f1fddfff30818754b5ac2328/funcsigs-1.0.2-py2.py3-none-any.whl
Collecting idna==2.5 (from -r /tmp/tmp.9CirkHigAi/letsencrypt-auto-requirements.txt (line 102))
  Downloading https://pypi.doubanio.com/packages/11/7d/9bbbd7bb35f34b0169542487d2a8859e44306bb2e6a4455d491800a5621f/idna-2.5-py2.py3-none-any.whl (55kB)
Collecting ipaddress==1.0.16 (from -r /tmp/tmp.9CirkHigAi/letsencrypt-auto-requirements.txt (line 105))
  Downloading https://pypi.doubanio.com/packages/23/6a/813ac29a01e4c33c19c2bded98ac3d4266ebbf0bd2c0eb0020e1c969958d/ipaddress-1.0.16-py27-none-any.whl
Collecting linecache2==1.0.0 (from -r /tmp/tmp.9CirkHigAi/letsencrypt-auto-requirements.txt (line 108))
  Downloading https://pypi.doubanio.com/packages/c7/a3/c5da2a44c85bfbb6eebcfc1dde24933f8704441b98fdde6528f4831757a6/linecache2-1.0.0-py2.py3-none-any.whl
Collecting ordereddict==1.1 (from -r /tmp/tmp.9CirkHigAi/letsencrypt-auto-requirements.txt (line 111))
  Downloading https://pypi.doubanio.com/packages/53/25/ef88e8e45db141faa9598fbf7ad0062df8f50f881a36ed6a0073e1572126/ordereddict-1.1.tar.gz
Collecting packaging==16.8 (from -r /tmp/tmp.9CirkHigAi/letsencrypt-auto-requirements.txt (line 113))
  Downloading https://pypi.doubanio.com/packages/87/1b/c39b7c65b5612812b83d6cab7ef2885eac9f6beb0b7b8a7071a186aea3b1/packaging-16.8-py2.py3-none-any.whl
Collecting parsedatetime==2.1 (from -r /tmp/tmp.9CirkHigAi/letsencrypt-auto-requirements.txt (line 116))
  Downloading https://pypi.doubanio.com/packages/85/1f/13fc06097e516f6259d62cea502b116451321c96e18a9d0fff9da3442e02/parsedatetime-2.1-py2-none-any.whl
Collecting pbr==1.8.1 (from -r /tmp/tmp.9CirkHigAi/letsencrypt-auto-requirements.txt (line 119))
  Downloading https://pypi.doubanio.com/packages/fc/37/94af8387babb09796d306b18cf94ee5c70388c875a16d8a88e471500452c/pbr-1.8.1-py2.py3-none-any.whl (89kB)
Collecting pyOpenSSL==16.2.0 (from -r /tmp/tmp.9CirkHigAi/letsencrypt-auto-requirements.txt (line 122))
  Downloading https://pypi.doubanio.com/packages/ac/93/b4cd538d31adacd07f83013860db6b88d78755af1f3fefe68ec22d397e7b/pyOpenSSL-16.2.0-py2.py3-none-any.whl (43kB)
Collecting pyparsing==2.1.8 (from -r /tmp/tmp.9CirkHigAi/letsencrypt-auto-requirements.txt (line 125))
  Downloading https://pypi.doubanio.com/packages/85/b9/188515f35f78533b3f82966a2c3f1a71a86df8b801367ee75a77191a861d/pyparsing-2.1.8-py2.py3-none-any.whl (54kB)
Collecting pyRFC3339==1.0 (from -r /tmp/tmp.9CirkHigAi/letsencrypt-auto-requirements.txt (line 134))
  Downloading https://pypi.doubanio.com/packages/9b/0a/decfa17e7707afca17d6e9595ff5c79c1c71c74063ad95576f897ed3a9f1/pyRFC3339-1.0-py2.py3-none-any.whl
Collecting python-augeas==0.5.0 (from -r /tmp/tmp.9CirkHigAi/letsencrypt-auto-requirements.txt (line 137))
  Downloading https://pypi.doubanio.com/packages/41/e6/4b6740cb3e31b82252099994cea751c648b846aa7874343c31d68c2215be/python-augeas-0.5.0.tar.gz (90kB)
Collecting pytz==2015.7 (from -r /tmp/tmp.9CirkHigAi/letsencrypt-auto-requirements.txt (line 139))
  Downloading https://pypi.doubanio.com/packages/c0/28/973f0382c803b21734cd7e97e0590928148ee21b1cbe8f7fed8b506204fb/pytz-2015.7-py2.py3-none-any.whl (476kB)
Collecting requests==2.12.1 (from -r /tmp/tmp.9CirkHigAi/letsencrypt-auto-requirements.txt (line 153))
  Downloading https://pypi.doubanio.com/packages/9b/31/e9925a2b9a06f97c3450bac6107928d3533bfe64ca5615442504104321e8/requests-2.12.1-py2.py3-none-any.whl (574kB)
Collecting six==1.10.0 (from -r /tmp/tmp.9CirkHigAi/letsencrypt-auto-requirements.txt (line 156))
  Downloading https://pypi.doubanio.com/packages/c8/0a/b6723e1bc4c516cb687841499455a8505b44607ab535be01091c0f24f079/six-1.10.0-py2.py3-none-any.whl
Collecting traceback2==1.4.0 (from -r /tmp/tmp.9CirkHigAi/letsencrypt-auto-requirements.txt (line 159))
  Downloading https://pypi.doubanio.com/packages/17/0a/6ac05a3723017a967193456a2efa0aa9ac4b51456891af1e2353bb9de21e/traceback2-1.4.0-py2.py3-none-any.whl
Collecting unittest2==1.1.0 (from -r /tmp/tmp.9CirkHigAi/letsencrypt-auto-requirements.txt (line 162))
  Downloading https://pypi.doubanio.com/packages/72/20/7f0f433060a962200b7272b8c12ba90ef5b903e218174301d0abfd523813/unittest2-1.1.0-py2.py3-none-any.whl (96kB)
Collecting zope.component==4.2.2 (from -r /tmp/tmp.9CirkHigAi/letsencrypt-auto-requirements.txt (line 165))
  Downloading https://pypi.doubanio.com/packages/4c/c4/3f77127c876f49af478e8ea4dc223cda17730bb273c0d1606a4114c64008/zope.component-4.2.2.tar.gz (546kB)
Collecting zope.event==4.1.0 (from -r /tmp/tmp.9CirkHigAi/letsencrypt-auto-requirements.txt (line 167))
  Downloading https://pypi.doubanio.com/packages/0e/87/75e3d62a3506953c2e56d15a150de31e5d92310e87db2c8b102dc01b0b8e/zope.event-4.1.0.tar.gz (476kB)
Collecting zope.interface==4.1.3 (from -r /tmp/tmp.9CirkHigAi/letsencrypt-auto-requirements.txt (line 169))
  Downloading https://pypi.doubanio.com/packages/9d/81/2509ca3c6f59080123c1a8a97125eb48414022618cec0e64eb1313727bfe/zope.interface-4.1.3.tar.gz (141kB)
Collecting mock==1.3.0 (from -r /tmp/tmp.9CirkHigAi/letsencrypt-auto-requirements.txt (line 188))
  Downloading https://pypi.doubanio.com/packages/b2/50/664a70b87408bb6c14c1af2337efa64eb8d1af80c933531758b8fb41ec25/mock-1.3.0-py2.py3-none-any.whl (56kB)
Collecting letsencrypt==0.7.0 (from -r /tmp/tmp.9CirkHigAi/letsencrypt-auto-requirements.txt (line 199))
  Downloading https://pypi.doubanio.com/packages/fd/21/0c6f33829fadec8aca0c1ebb4d6f8101c05899356a58d1b2e506cb77cf18/letsencrypt-0.7.0-py2-none-any.whl
Collecting certbot==0.20.0 (from -r /tmp/tmp.9CirkHigAi/letsencrypt-auto-requirements.txt (line 203))
  Could not find a version that satisfies the requirement certbot==0.20.0 (from -r /tmp/tmp.9CirkHigAi/letsencrypt-auto-requirements.txt (line 203)) (from versions: 0.6.0, 0.7.0, 0.8.0, 0.8.1, 0.9.0, 0.9.1, 0.9.2, 0.9.3, 0.10.0, 0.10.1, 0.10.2, 0.11.0, 0.11.1, 0.12.0, 0.13.0, 0.14.0, 0.14.1, 0.14.2, 0.15.0, 0.16.0, 0.17.0, 0.18.0, 0.18.1, 0.18.2, 0.19.0)
No matching distribution found for certbot==0.20.0 (from -r /tmp/tmp.9CirkHigAi/letsencrypt-auto-requirements.txt (line 203))
=====================================================

Certbot has problem setting up the virtual environment.

We were not be able to guess the right solution from your pip
output.

Consult https://certbot.eff.org/docs/install.html#problems-with-python-virtual-environment
for possible solutions.
You may also find some support resources at https://certbot.eff.org/support/ .
Let's Encrypt SSL Certificate create failed!
然后我测试手动更新证书  /bin/certbot renew --disable-hook-validation --renew-hook "/etc/init.d/nginx reload"
也是一样的错误
我之前的网站,在11月22日,还正常自动更新过证书,11月份来我没进行服务器任何操作,不知道是我的服务器问题还是Let'sEncrypt又有新更新

TOP

问题解决pip.conf更改源解决;
阿里云主机更换为 https://mirrors.aliyuncs.com/pypi/simple/  都不用下载
非阿里云可以更换为 https://mirrors.aliyun.com/pypi/simple/

当然还有其它的,我没测试

TOP

TOP