打印

404 Not Found 请问一下。。我添加了SSL证书以后。HTTPS还是无法查找怎么办

回复 13# 的帖子

我修改以后重启lnmp 变成这样了


Shutting down MySQL. SUCCESS!
Gracefully shutting down php-fpm  done
Starting LNMP...
Starting nginx... nginx (pid 12602 12600) already running.
Starting MySQL.. SUCCESS!
Starting php-fpm  done

TOP

回复 15# 的帖子

你写的这么乱,
给你看看我这的虚拟主机的配置
server {
        listen 80;
        server_name www.xx.top;
        rewrite ^(.*) https://$host$1 permanent;
}

server
    {
        listen 443;
        #listen [::]:80;
        server_name www.xx2.top;
        index index.html index.htm index.php default.html default.htm default.php;
        root  /www/xx2/;
                ssl on;
        ssl_certificate cert/www.xx2.top.crt;
        ssl_certificate_key cert/www.xx2.top.key;
        ssl_session_timeout 5m;
        ssl_protocols TLSv1 TLSv1.1 TLSv1.2;
        ssl_ciphers ECDHE-RSA-AES128-GCM-SHA256:HIGH:!aNULL:!MD5:!RC4:!DHE;
        ssl_prefer_server_ciphers on;
        include /usr/local/nginx/conf/rewrite/xx2.conf;
        error_page   404   /404.html;

        # Deny access to PHP files in specific directory
        location ~ /(wp-content|uploads|wp-includes|images)/.*\.php$ { deny all; }

        include enable-php.conf;

        location ~ .*\.(gif|jpg|jpeg|png|bmp|swf)$
        {
            expires      30d;
        }

        location ~ .*\.(js|css)?$
        {
            expires      12h;
        }

        location ~ /.well-known {
            allow all;
        }

        location ~ /\.
        {
            deny all;
        }

        access_log /var/log/www.xx2.top.log;
    }
感觉你写的太乱了,一个跳转,都写了那么多没有用的。

TOP

回复 17# 的帖子

谢谢   我弄好了

TOP

回复 2# 的帖子

谢谢军哥  我弄好了

TOP