打印

LNMP 1.5集成的acme.sh问题多多

LNMP 1.5集成的acme.sh问题多多

按照教程DNS API方式总是提示“无效的域名主机”,使用lnmp dnsssl方式120秒通过后提示Let's Encrypt SSL Certificate create failed!,使用lnmp dns cx来申请也是提示“无效的域名主机”,如何彻底删除LNMP1.5集成的这个acme.sh呢!自己安装acme.sh来申请证书?
不用集成的这个acme.sh一切都非常的顺利!

[ 本帖最后由 明月登楼 于 2018-4-2 17:56 编辑 ]

TOP

可以尝试 /usr/local/acme.sh/acme.sh --upgrade 升级一下acme.sh,release里的2.7.8 好像有问题

LNMP付费问题排查/LNMP技术支持/Paypal信用卡代付/代购VPS,域名,软件等 QQ 503228080 旺旺 lzhenbao
军哥淘宝店铺
QQ/旺旺仅提供代购及付费代维/问题解决等服务,其他不回复!LNMP相关问题请在本论坛发帖,提问前先搜索,按https://bbs.vpser.net/thread-2555-1-1.html 要求反馈问题!

TOP

回复 2# 的帖子

升级后还是2.7.8

TOP

还是这个错误:
[Mon Apr  2 23:28:38 CST 2018] Found domain api file: /usr/local/acme.sh/dnsapi/dns_cx.sh
[Mon Apr  2 23:28:39 CST 2018] invalid domain
[Mon Apr  2 23:28:39 CST 2018] Error add txt for domain:_acme-challenge.xunyingjy.com
[Mon Apr  2 23:28:39 CST 2018] Please add '--debug' or '--log' to check more details.
[Mon Apr  2 23:28:39 CST 2018] See: https://github.com/Neilpang/acme.sh/wiki/How-to-debug-acme.sh

TOP

我已经是导入DNS的API了!

TOP

引用:
原帖由 licess 于 2018-4-2 19:11 发表
可以尝试 /usr/local/acme.sh/acme.sh --upgrade 升级一下acme.sh,release里的2.7.8 好像有问题
升级了acme.sh后,错误依然如故,日志请查阅附件!

附件: 您所在的用户组无法下载或查看附件

TOP

回复 6# 的帖子

请加上  --log-level 2 或者  --debug 2

TOP

回复 2# 的帖子

[root@Fh]# acme.sh  --upgrade  --auto-upgrade
[Mon Apr  2 23:48:06 EDT 2018] Installing from online archive.
[Mon Apr  2 23:48:06 EDT 2018] Downloading https://github.com/Neilpang/acme.sh/archive/master.tar.gz
[Mon Apr  2 23:48:07 EDT 2018] Please refer to https://curl.haxx.se/libcurl/c/libcurl-errors.html for error code: 35
[Mon Apr  2 23:48:07 EDT 2018] Download error.
[Mon Apr  2 23:48:07 EDT 2018] Upgrade failed!

军哥,这个升级报错。咋整。

TOP

引用:
原帖由 Neil 于 2018-4-3 09:40 发表
请加上  --log-level 2 或者  --debug 2
已经加上  --log-level 2 和  --debug 2参数的日志文件!

求军哥解惑释义!
附件: 您所在的用户组无法下载或查看附件

TOP

回复 8# 的帖子

这个报错估计你系统是centos,yum install nss 后再试一下看看

LNMP付费问题排查/LNMP技术支持/Paypal信用卡代付/代购VPS,域名,软件等 QQ 503228080 旺旺 lzhenbao
军哥淘宝店铺
QQ/旺旺仅提供代购及付费代维/问题解决等服务,其他不回复!LNMP相关问题请在本论坛发帖,提问前先搜索,按https://bbs.vpser.net/thread-2555-1-1.html 要求反馈问题!

TOP

回复 9# 的帖子

neil应该是acme.sh作者

[Tue Apr  3 15:57:27 CST 2018] response='{"code":403,"message":"47.97.207.68 is not in whitelist"}'
[Tue Apr  3 15:57:27 CST 2018] invalid domain
[Tue Apr  3 15:57:27 CST 2018] Error add txt for domain:_acme-challenge.nyydjy.com
你是不是在api上设置ip白名单了?

LNMP付费问题排查/LNMP技术支持/Paypal信用卡代付/代购VPS,域名,软件等 QQ 503228080 旺旺 lzhenbao
军哥淘宝店铺
QQ/旺旺仅提供代购及付费代维/问题解决等服务,其他不回复!LNMP相关问题请在本论坛发帖,提问前先搜索,按https://bbs.vpser.net/thread-2555-1-1.html 要求反馈问题!

TOP

回复 11# 的帖子

这个好像没有,我第一次知道API还能设置白名单?
我先试试更新NSS再说!

TOP

回复 10# 的帖子

Package nss-3.28.4-15.el7_4.x86_64 already installed and latest version
已经是最新版本了!

TOP

回复 11# 的帖子

不是白名单的问题,因为我用另外一个主机上的 GitHub 的acme.sh申请一次就过了!同样的API呀!

TOP

回复 11# 的帖子

军哥,膜拜一下!真叫你说对了!还真的是API白名单的问题!:L

TOP