打印

1.5 ubuntu 18.04 server 安装失败

1.5 ubuntu 18.04 server 安装失败

1.5 ubuntu 18.04 server 安装失败.

Mysql8.0 不支持 MySQL55MAOpt="-DCMAKE_EXE_LINKER_FLAGS='-ljemalloc' -DWITH_SAFEMALLOC=OFF"
复制内容到剪贴板
代码:
Install_MySQL_80()
{
    Install_Boost
    Echo_Blue "[+] Installing ${Mysql_Ver}..."
    rm -f /etc/my.cnf
    Tar_Cd ${Mysql_Ver}.tar.gz ${Mysql_Ver}
    cmake -DCMAKE_INSTALL_PREFIX=/usr/local/mysql -DSYSCONFDIR=/etc -DWITH_MYISAM_STORAGE_ENGINE=1 -DWITH_INNOBASE_STORAGE_ENGINE=1 -DWITH_PARTITION_STORAGE_ENGINE=1 -DWITH_FEDERATED_STORAGE_ENGINE=1 -DEXTRA_CHARSETS=all -DDEFAULT_CHARSET=utf8mb4 -DDEFAULT_COLLATION=utf8mb4_general_ci -DWITH_EMBEDDED_SERVER=1 -DENABLED_LOCAL_INFILE=1 -DWITH_BOOST=${cur_dir}/src/${Boost_New_Ver} ${MySQL55MAOpt}
    Make_Install
[ 本帖最后由 kekeones 于 2018-5-3 22:24 编辑 ]
附件: 您所在的用户组无法下载或查看附件

TOP

有可能mysql 8.0变化较多有调整

LNMP付费问题排查/LNMP技术支持/Paypal信用卡代付/代购VPS,域名,软件等 QQ 503228080 旺旺 lzhenbao
军哥淘宝店铺
QQ/旺旺仅提供代购及付费代维/问题解决等服务,其他不回复!LNMP相关问题请在本论坛发帖,提问前先搜索,按https://bbs.vpser.net/thread-2555-1-1.html 要求反馈问题!

TOP

回复 2# 的帖子

mysql8.0 和php7.2 也会失败,cmake依赖libcurl4而不是libcurl3

[ 本帖最后由 kekeones 于 2018-5-7 21:36 编辑 ]

TOP

回复 3# 的帖子

不清楚你是什么服务商的vps,18.04我们这边linode的、vmware、esxi上都测试过没问题有问题

LNMP付费问题排查/LNMP技术支持/Paypal信用卡代付/代购VPS,域名,软件等 QQ 503228080 旺旺 lzhenbao
军哥淘宝店铺
QQ/旺旺仅提供代购及付费代维/问题解决等服务,其他不回复!LNMP相关问题请在本论坛发帖,提问前先搜索,按https://bbs.vpser.net/thread-2555-1-1.html 要求反馈问题!

TOP

回复 4# 的帖子

还没上生产环境,本地使用物理机和虚拟机安装的即使不选内存优化,也是安装失败.
我的是服务器版的Ubuntu Server 18.04
不选择内存优化,Mysql 8.0安装失败,libcurl3改libcurl4 Mysql 编译成功了,PHP编译失败

[ 本帖最后由 kekeones 于 2018-5-7 21:54 编辑 ]

TOP

mysql 8.0没有与libcurl有依赖关系linode的模板都是服务器版的
昨天晚上再次测试依然正常
附件: 您所在的用户组无法下载或查看附件

LNMP付费问题排查/LNMP技术支持/Paypal信用卡代付/代购VPS,域名,软件等 QQ 503228080 旺旺 lzhenbao
军哥淘宝店铺
QQ/旺旺仅提供代购及付费代维/问题解决等服务,其他不回复!LNMP相关问题请在本论坛发帖,提问前先搜索,按https://bbs.vpser.net/thread-2555-1-1.html 要求反馈问题!

TOP

回复 6# 的帖子

[mysqld_safe]
malloc-lib=/usr/local/lib/libjemalloc.so

mysql 加载Jemalloc 或TCMalloc 是否可以用以上方式来加载.这样所有版本的Mysql 就可以使用Jemalloc 或TCMalloc
因为选了Jemalloc 或TCMalloc,不止对Mysql,还可以用于Nginx

[ 本帖最后由 kekeones 于 2018-5-8 14:20 编辑 ]

TOP

回复 7# 的帖子

5.5以上版本应该是可以使用这种方式

LNMP付费问题排查/LNMP技术支持/Paypal信用卡代付/代购VPS,域名,软件等 QQ 503228080 旺旺 lzhenbao
军哥淘宝店铺
QQ/旺旺仅提供代购及付费代维/问题解决等服务,其他不回复!LNMP相关问题请在本论坛发帖,提问前先搜索,按https://bbs.vpser.net/thread-2555-1-1.html 要求反馈问题!

TOP

回复 8# 的帖子

有望加到lnmp1.5里吗。这样对生产环境是友好的

TOP