打印

怎样才能初始就安装上php 7.2.7而不是lnmp v1.5目前自带的7.2.6呢?

怎样才能初始就安装上php 7.2.7而不是lnmp v1.5目前自带的7.2.6呢?

1.5自带的是7.2.6,我有个想法,直接装成7.2.7,如此一来,就可以不用安装完成之后再进行php的升级了。
我是这样试的:
我把php的源码包从php网站上下下来,放到默认的lnmp一键包的安装目录里,然后把7.2.6的包删除,再执行自动安装代码,我想,它应当会在安装过程中自己找到7.2.7的包进行编译安装。

但实际情况是这样的:
安装过程中它发现没有7.2.6的包,然后就下载了编译安装。这样当一键包全部安装完成后,环境中的php仍然是7.2.6。

想了想,也许是安装程序中写死了版本是7.2.6?但看了下安装代码中又找不到7.2.6这个具体的版本号,最多只到第二位版本。

请问如果想直接安装成7.2.7该怎么操作呢?内存是512MB的,上回没注意,被锁了CPU的时钟了。

TOP

论坛里早就提供方法了
自己修改include/version.sh 下载指定版本的tar.bz2包到 src 目录下

LNMP付费问题排查/LNMP技术支持/Paypal信用卡代付/代购VPS,域名,软件等 QQ 503228080 旺旺 lzhenbao
军哥淘宝店铺
QQ/旺旺仅提供代购及付费代维/问题解决等服务,其他不回复!LNMP相关问题请在本论坛发帖,提问前先搜索,按https://bbs.vpser.net/thread-2555-1-1.html 要求反馈问题!

TOP

引用:
原帖由 licess 于 2018-7-16 08:35 发表
论坛里早就提供方法了
自己修改include/version.sh 下载指定版本的tar.bz2包到 src 目录下
多谢licess。

搜索关键词原来用英文的version就可以了,找到这几个:
https://bbs.vpser.net/viewthread.php?tid=17142
https://bbs.vpser.net/viewthread.php?tid=16092
https://bbs.vpser.net/viewthread.php?tid=16046
https://bbs.vpser.net/viewthread.php?tid=13817

TOP